zoukankan      html  css  js  c++  java
  • POJ 3616 Milking Time(简单区间DP)

    Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

    Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

    Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

    Input

    * Line 1: Three space-separated integers: NM, and R
    * Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

    Output

    * Line 1: The maximum number of gallons of milk that Bessie can product in the Nhours

    Sample Input

    12 4 2
    1 2 8
    10 12 19
    3 6 24
    7 10 31

    Sample Output

    43
    题意:
      
      奶牛Bessie在0~N时间段产奶。农夫约翰有M个时间段可以挤奶,时间段st,end内Bessie能挤到的牛奶量ef。奶牛产奶后需要休息R小时才能继续下一次产奶,求Bessie最大的挤奶量。
    题解:

      区间DP,每个区间带有权重。定义dp[i]表示前i个时间段挤奶能够得到的最大值,递推关系式有dp[i]= 前i–1 个时间段挤奶最大值中的最大值+第i次产奶量。
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int maxm=1e4+5;
    int dp[maxm];
    struct val
    {
        int st,end,ef;
        bool operator < (const val& a) const
        {
            return st<a.st;
        }
    }T[maxm];
    int main()
    {
        int n,m,r;
        cin>>n>>m>>r;
        for(int i=1;i<=m;i++)
        {
            cin>>T[i].st>>T[i].end>>T[i].ef;
            T[i].end+=r;
        }
        sort(T+1,T+1+m);     
        for(int i=1;i<=m;i++)
        {
            dp[i]=T[i].ef;
            for(int j=1;j<i;j++)
                if(T[j].end<=T[i].st)
                    dp[i]=max(dp[i],dp[j]+T[i].ef);
        }
        cout<<*max_element(dp+1,dp+1+m)<<endl;
        return 0;
    }
    
    
    
     
  • 相关阅读:
    百度API车牌识别——Restful方式
    cxgrid 满足条件颜色显示
    cxgrid 增加右键菜单
    折线图堆积图
    echarts 堆积图
    echarts 柱型图和折线图组合
    图表自动轮播
    Delphi D10.3 FMX android 调用自带浏览器打开网页
    echarts-JSON请求数据
    堆叠条形图
  • 原文地址:https://www.cnblogs.com/orion7/p/7506473.html
Copyright © 2011-2022 走看看