zoukankan      html  css  js  c++  java
  • POJ 1862 Stripies (简单贪心)

    Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2sqrt(m1m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
    You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
    Input
    The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
    Output
    The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
    Sample Input
    3
    72
    30
    50
    Sample Output
    120.000

    题意:

    如果一个质量为m1和m2的stripies相撞,生成的stripies体重是2sqrt(m1m2) 。现在,科学家们想知道,如果stripies两两碰撞至只剩一个,则这一个的最小质量是多少?

    题解:

    优选选取序列中最大质量的两个,可以用优先队列,当然也可以不用。

    #include<iostream>
    #include<algorithm>
    #include<cmath>
    #include<cstdio>
    using namespace std;
    int a[105];
    int main()
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>a[i];
        sort(a,a+n);
        double ans=a[n-1];
        for(int i=n-2;i>=0;i--)
        {
            ans=2*sqrt(ans*a[i]);
        }
        cout.setf(ios::fixed);
        cout.precision(3);
        cout<<ans<<endl;
        return 0;
    }
    
  • 相关阅读:
    fastjson-alibaba
    ubuntu 入门
    资料文档
    asp.net mvc View视图相关
    视频
    js第三方
    工具类网址
    [转]初学者的编程自学指南
    seajs的使用--主要了解模块化
    其它
  • 原文地址:https://www.cnblogs.com/orion7/p/7828079.html
Copyright © 2011-2022 走看看