zoukankan      html  css  js  c++  java
  • A Mathematical Curiosity

    A Mathematical Curiosity

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 87   Accepted Submission(s) : 23

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.

    Input

    You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.

    Output

    For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.

    Sample Input

    1
    
    10 1
    20 3
    30 4
    0 0
    

    Sample Output

    Case 1: 2
    Case 2: 4
    Case 3: 5
        #include<iostream>
    using namespace std;
        int main()
        {
            int a,b,m,n,k,j,i,ans,num;
            cin>>k;
            for(b=0;b<k;b++)
            {    num=0;
                
                if(b)
                    cout<<endl;
                while(cin>>n>>m&&m||n)
                {ans=0;
                
                    for(i=1;i<n;i++)
                        for(j=i+1;j<n;j++)
                        {
                            if((i*i+j*j+m)%(i*j)==0)
                                ans++;
    
    
                        }
                        cout<<"Case "<<++num<<": "<<ans<<endl;
                }
            }
          
             
            return 0;
        }

  • 相关阅读:
    eclipse下载
    maven-jdk版本配置
    winform中的ListBox和ComboBox绑定数据
    C和C#两种方式实现邮件的简单接收
    .Net遍历窗体上控件
    C和C#两种方式实现邮件的简单发送
    Gtk基础学习总结(二)
    Gtk基础学习总结(一)
    你要知道的C与C++的区别
    C程序中引用自定义的C函数模块
  • 原文地址:https://www.cnblogs.com/oversea201405/p/3766935.html
Copyright © 2011-2022 走看看