zoukankan      html  css  js  c++  java
  • Digital Roots


    Problem Descriptio

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

    Output

    For each integer in the input, output its digital root on a separate line of the output.

    Sample Input

    24
    39
    0
    

    Sample Output

    6
    3
    #include<iostream>
    //#include<stdio.h>
    using namespace std;
    int main()
    {
    char  a[1001];
    	int n,i,m;
    	while(gets(a)&&a[0]!='0')
    	{
    		m=0;
    	n=strlen(a);
    	for(i=0;i<n;i++)
          m+=a[i]-48;
    	if(m%9==0)
    		cout<<9<<endl;
    	else
    	cout<<m%9<<endl;
    	
    	
    	
    	}
    return 0;
    }


  • 相关阅读:
    软件工程结对作业02(原创版)
    第六周学习进度条
    软件工程结对作业02(借鉴版)
    软件工程课堂测试06
    第五周学习进度条
    构建之法阅读笔记02
    软件工程个人作业03
    第四周学习进度条
    构建之法阅读笔记01
    CentOS7下解决ifconfig command not found的办法
  • 原文地址:https://www.cnblogs.com/oversea201405/p/3766954.html
Copyright © 2011-2022 走看看