zoukankan      html  css  js  c++  java
  • UVA 536 (13.08.17)

     Tree Recovery 

    Little Valentine liked playing with binary trees very much. Her favoritegame was constructingrandomly looking binary trees with capital letters in the nodes.

    This is an example of one of her creations:

                                        D
                                       / 
                                      /   
                                     B     E
                                    /      
                                   /         
                                  A     C     G
                                             /
                                            /
                                           F
    

    To record her trees for future generations, she wrote down two stringsfor each tree: a preordertraversal (root, left subtree, right subtree) and an inorder traversal(left subtree, root, right subtree).

    For the tree drawn above the preorder traversal is DBACEGF and theinorder traversal isABCDEFG.

    She thought that such a pair of strings would give enough information toreconstruct the tree later (but she never tried it).


    Now, years later, looking again at the strings, she realized thatreconstructing the trees was indeedpossible, but only because she never had used the same letter twicein the same tree.

    However, doing the reconstruction by hand, soon turned out to be tedious.

    So now she asks you to write a program that does the job for her!

    Input Specification 

    The input file will contain one or more test cases.Each test case consists of one line containing two strings preord andinord, representing thepreorder traversal and inorder traversal of a binary tree. Both stringsconsist of unique capitalletters. (Thus they are not longer than 26 characters.)

    Input is terminated by end of file.

    Output Specification 

    For each test case, recover Valentine's binary tree and print one linecontaining the tree's postordertraversal (left subtree, right subtree, root).

    Sample Input 

    DBACEGF ABCDEFG
    BCAD CBAD
    

    Sample Output 

    ACBFGED
    CDAB
    


    题意: 给出前序和中序, 求后序

    做法: 递归建树, 刘汝佳<算法竞赛-入门经典>中的 二叉树重建 部分有讲


    AC代码:

    #include<stdio.h>
    #include<string.h>
    
    void build(int n, char *s1, char *s2, char *s) {
        if(n <= 0)
            return;
        int p = strchr(s2, s1[0]) - s2;
        build(p, s1+1, s2, s);
        build(n-1-p, s1+p+1, s2+p+1, s+p);
        s[n-1] = s1[0];
    }
    
    int main() {
        char str1[30], str2[30];
        char ans[30];
        int len;
        while(scanf("%s%s", str1, str2) != EOF) {
            len = strlen(str1);
            build(len, str1, str2, ans);
            ans[len] = '';
            puts(ans);
        }
        return 0;
    }
  • 相关阅读:
    sharepoint JQ获取List列表的值
    微信修改域名回掉
    input设置只读
    MVC-AJAX-JSON
    sharepoint添加子网站
    sharepoint打开解决方案库
    前台获取参数值
    SQL查看表结构以及表说明
    JQ获取对象属性值
    bootstrap table样式
  • 原文地址:https://www.cnblogs.com/pangblog/p/3266739.html
Copyright © 2011-2022 走看看