zoukankan      html  css  js  c++  java
  • hdu4708


    Rotation Lock Puzzle

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 571    Accepted Submission(s): 153

    Problem Description
    Alice was felling into a cave. She found a strange door with a number square matrix. These numbers can be rotated around the center clockwise or counterclockwise. A fairy came and told her how to solve this puzzle lock: “When the sum of main diagonal and anti-diagonal is maximum, the door is open.”.
    Here, main diagonal is the diagonal runs from the top left corner to the bottom right corner, and anti-diagonal runs from the top right to the bottom left corner. The size of square matrix is always odd.



    This sample is a square matrix with 5*5. The numbers with vertical shadow can be rotated around center ‘3’, the numbers with horizontal shadow is another queue. Alice found that if she rotated vertical shadow number with one step, the sum of two diagonals is maximum value of 72 (the center number is counted only once).
     
    Input
    Multi cases is included in the input file. The first line of each case is the size of matrix n, n is a odd number and 3<=n<=9.There are n lines followed, each line contain n integers. It is end of input when n is 0 .
     
    Output
    For each test case, output the maximum sum of two diagonals and minimum steps to reach this target in one line.
     
    Sample Input
    5 9 3 2 5 9 7 4 7 5 4 6 9 3 9 3 5 2 8 7 2 9 9 4 1 9 0
     
    Sample Output
    72 1
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<iomanip>
    #define INF 99999999
    using namespace std;
    
    const int MAX=10;
    int s[MAX][MAX];
    
    int main(){
    	int n;
    	while(scanf("%d",&n),n){
    		for(int i=0;i<n;++i){
    			for(int j=0;j<n;++j)scanf("%d",&s[i][j]);
    		}
    		int sum=0,num=0,temp=0,k; 
    		for(int i=0;i<n/2;++i){//从第i行开始的四边形 
    			k=0,temp=-INF;
    			for(int j=0;j<=n-2*i-2;++j){//分别计算顺时针旋转j(逆时针旋转n-2*i-1-j次)次后左上角,左下角,右上角,右下角相加的和 
    				if(s[i+j][i]+s[n-1-i][i+j]+s[i][n-1-i-j]+s[n-1-i-j][n-1-i]>temp){
    					temp=s[i+j][i]+s[n-1-i][i+j]+s[i][n-1-i-j]+s[n-1-i-j][n-1-i];
    					k=j;
    				}
    			}
    			sum+=temp;
    			num+=min(k,n-2*i-1-k);
    		}
    		cout<<sum+s[n/2][n/2]<<' '<<num<<endl;
    	}
    	return 0;
    }


  • 相关阅读:
    Servlet编程实例1
    Servlet
    JDBC之代码优化
    JDBC数据库编程
    数据库常识
    数据库基本操作
    STM32CUBEMX入门学习笔记3:HAL库以及STM32CUBE相关资料
    QT入门学习笔记2:QT例程
    爬虫制作入门学习笔记2:[转]python爬虫实例项目大全
    中移物联网onenet入门学习笔记2:中移物联的通信格式
  • 原文地址:https://www.cnblogs.com/pangblog/p/3313375.html
Copyright © 2011-2022 走看看