zoukankan      html  css  js  c++  java
  • POJ1734/Floyd求最小环

    Sightseeing trip
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 6647   Accepted: 2538   Special Judge

    Description

    There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

    In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

    Input

    The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

    Output

    There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

    Sample Input

    5 7
    1 4 1
    1 3 300
    3 1 10
    1 2 16
    2 3 100
    2 5 15
    5 3 20
    

    Sample Output

    1 3 5 2
    

    Source

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    const int MAXN=105;
    const int INF=1e6;//改成1e9就不对了
    int dis[MAXN][MAXN],mp[MAXN][MAXN];
    int R[MAXN][MAXN],path[MAXN];
    int N,M,len;
    int u,v,w;
    int cnt=0;
    void Init()
    {
        for(int i=0;i<=N;i++)
            for(int j=0;j<=N;j++)
            dis[i][j]=INF,R[i][j]=0;
        cnt=0;
    }
    void Path(int s,int t)
    {
        if(R[s][t])
        {
            Path(s,R[s][t]);
            Path(R[s][t],t);
        }
        else
            path[++cnt]=t;
    }
    void Floyd()
    {
        len=INF;
        for(int k=1;k<=N;k++)
        {
        //判断负环 for(int i=1;i<k;i++) for(int j=i+1;j<k;j++) { if(len>dis[i][j]+mp[i][k]+mp[k][j]) { len=dis[i][j]+mp[i][k]+mp[k][j]; cnt=0; path[++cnt]=i; Path(i,j); path[++cnt]=k; } }      //求最短路 for(int i=1;i<=N;i++) for(int j=1;j<=N;j++) { if(dis[i][j]>dis[i][k]+dis[k][j]) { dis[i][j]=dis[i][k]+dis[k][j]; R[i][j]=k; } } } } int main () { while(~scanf("%d%d",&N,&M)) { Init(); for(int i=1;i<=M;i++) { scanf("%d%d%d",&u,&v,&w); if(dis[u][v]>w)//记录重边 { dis[u][v]=w; dis[v][u]=w; } } for(int i=1;i<=N;i++) for(int j=1;j<=N;j++) mp[i][j]=dis[i][j];//mp判断环的时候要用到 Floyd(); if(len==INF) printf("No solution. "); else { for(int i=1;i<=cnt;i++) { if(i!=cnt) printf("%d ",path[i]); else printf("%d ",path[i]); } } } return 0; }

      

    想的太多,做的太少。
  • 相关阅读:
    计算最大公约数 Exercise05_14
    求满足n^2>12000的n的最大值 Exercise05_13
    依赖注入(DI)
    spring容器
    基于xml文件的bean的配置
    小试牛刀 spring的HelloWorld
    spring 装配Bean
    spring介绍
    hibernate相关类与接口
    hibernate 预习
  • 原文地址:https://www.cnblogs.com/pealicx/p/6130926.html
Copyright © 2011-2022 走看看