zoukankan      html  css  js  c++  java
  • HDU 5666 Segment

    Segment

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
    Total Submission(s): 1082    Accepted Submission(s): 398


    Problem Description
        Silen August does not like to talk with others.She like to find some interesting problems.

        Today she finds an interesting problem.She finds a segment x+y=q.The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

        Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
     
    Input
        First line has a number,T,means testcase number.

        Then,each line has two integers q,P.

        q is a prime number,and 2q1018,1P1018,1T10.
     
    Output
        Output 1 number to each testcase,answer mod P.
     
    Sample Input
    1 2 107
     
    Sample Output
    0
     
    题目就是求直线与坐标轴围成的区域内有多少个点(整数)我们可以发现 点的数量是成等差数列的  求和就ok了  注意数据范围 
    import java.util.*;
    import java.math.*;
    public class Main {
        public static void main(String []args){
            Scanner cin=new Scanner(System.in);
            int n;
            BigInteger a,b,e;
            n=cin.nextInt();
            for(int i=1;i<=n;i++){
                a=cin.nextBigInteger();
                b=cin.nextBigInteger();
                BigInteger c=new BigInteger("2");
                BigInteger d=new BigInteger("1");
                a=a.subtract(c);
                e=a.multiply(a).add(a);
                e=e.divide(c);
                e=e.mod(b);
                System.out.println(e);
            }
        }
    
    }
     
  • 相关阅读:
    字符串匹配之朴素匹配
    XSS的攻击原理
    使用metasploit收集邮箱
    C++实现折半插入排序
    C++插入排序实现
    Java中的NIO
    Hashtable和HashMap区别(面试)
    面向对象:封装(一):构造函数;类的主方法;权限修饰符;对象的创建
    switch多分支语句
    递归和字母数字生成随机数
  • 原文地址:https://www.cnblogs.com/pk28/p/5422436.html
Copyright © 2011-2022 走看看