zoukankan      html  css  js  c++  java
  • poj 3253 Fence Repair

    Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

    FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

    Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

    Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

    Input

    Line 1: One integer N, the number of planks 
    Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

    Output

    Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

    Sample Input

    3
    8
    5
    8

    Sample Output

    34

    Hint

    He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
    The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

    题目大意:

    把一个木棒切成 n部分,每部分的花费 是分成的两块木棒的和。求分成n个木棒的最少花费。

    贪心的去做,先合并两个最小的,和剩下的n-2块放在一起。在处理这n-1块,再在这n-1中选着两个最小的......   就得到了答案

    /* ***********************************************
    Author        :guanjun
    Created Time  :2016/10/31 10:18:43
    File Name     :poj3253.cpp
    ************************************************ */
    #include <iostream>
    #include <set>
    #include <cstdio>
    #include <queue>
    
    #define ull unsigned long long
    #define ll long long
    #define mod 90001
    #define INF 0x3f3f3f3f
    #define maxn 10010
    #define cle(a) memset(a,0,sizeof(a))
    const ull inf = 1LL << 61;
    const double eps=1e-5;
    using namespace std;
    priority_queue<ll,vector<ll>,greater<ll> >pq;
    struct Node{
        int x,y;
    };
    struct cmp{
        bool operator()(Node a,Node b){
            if(a.x==b.x) return a.y> b.y;
            return a.x>b.x;
        }
    };
    
    bool cmp(int a,int b){
        return a>b;
    }
    int main()
    {
        #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        #endif
        //freopen("out.txt","w",stdout);
        int n;
        ll xx;
        cin>>n;
        for(int i=1;i<=n;i++){
            scanf("%lld",&xx);
            pq.push(xx);
        }
        ll ans=0;
        while(!pq.empty()){
            ll x=pq.top();pq.pop();
            ll y=-1;
            
            if(!pq.empty()){
                y=pq.top();
                pq.pop();
            }
            if(y!=-1){
                pq.push(x+y);
                ans+=(x+y);
            }
            else{
                break;
            }
            //cout<<"y "<<y<<endl;
        }
        cout<<ans<<endl;
        return 0;
    }
  • 相关阅读:
    Promise、Async、await
    Generator
    模块化
    继承
    原型
    == vs ===
    深浅拷贝
    this
    nodejs中搭建服务器
    sql中constraint主要是增加约束
  • 原文地址:https://www.cnblogs.com/pk28/p/6040417.html
Copyright © 2011-2022 走看看