zoukankan      html  css  js  c++  java
  • zoj--2770--Burn the Linked Camp(差分约束)

    Time Limit: 2000MS   Memory Limit: 65536KB   64bit IO Format: %lld & %llu

    Status

    Description

    It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

    Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

    Input:

    There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

    Output:

    For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

    Sample Input:

    3 2
    1000 2000 1000
    1 2 1100
    2 3 1300
    3 1
    100 200 300
    2 3 600
    

    Sample Output:

    1300
    Bad Estimations

    Input

    Output

    Sample Input

    Sample Output

    Hint

    Source

    ZOJ Monthly, October 2006


    现有n个军营,并且知道里边的容量,现在给你m条信息,a b c表示a--b最少有c人,请判断这几个军营最少有多少人,如果不能判断就输出Bad Estimations

    因为给了最少有多少人,我们应该转化为b-a<=c的形式,这算作一个条件,同时每个军营里人数不能超出容量也就是i-(i-1)<=man[i],0<=i-(i-1)

    <pre name="code" class="cpp">#include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<queue>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    #define INF 0x3f3f3f
    #define MAXN 50000
    int n,m,head[MAXN],l,r,cnt;
    int vis[MAXN],totle[MAXN],man[MAXN],dis[MAXN],used[MAXN];
    struct node
    {
    	int u,v,val;
    	int next;
    }edge[100000];
    void init()
    {
    	memset(head,-1,sizeof(head));
    	memset(man,0,sizeof(man));
    	memset(used,0,sizeof(used));
    	memset(totle,0,sizeof(totle));
    	cnt=0;
    }
    void add(int u,int v,int val)
    {
    	node E={u,v,val,head[u]};
    	edge[cnt]=E;
    	head[u]=cnt++;
    }
    void getmap()
    {
    	for(int i=1;i<=n;i++)
    	{
    		cin>>man[i];
    		totle[i]=man[i]+totle[i-1];
    		add(i-1,i,man[i]);
    		add(i,i-1,0);
    	}
    	for(int i=0;i<m;i++)
    	{
    		int a,b,c;
    		cin>>a>>b>>c;
    		add(b,a-1,-c);
    		add(a-1,b,totle[b]-totle[a-1]); //连续的营地不能超过总的容量
    		//刚开始没加这一条,但是还是过了 
    	}
    }
    bool SPFA()
    {
    	queue<int>q;
    	memset(vis,0,sizeof(vis));
    	memset(dis,INF,sizeof(dis));
    	dis[n]=0;
    	vis[n]=1;
    	q.push(n);
    	used[n]++;
    	while(!q.empty())
    	{
    		int u=q.front();
    		q.pop();
    		vis[u]=0;
    		for(int i=head[u];i!=-1;i=edge[i].next)
    		{
    			node E=edge[i];
    			if(dis[E.v]>dis[u]+edge[i].val)
    			{
    				dis[E.v]=dis[E.u]+edge[i].val;
    				if(!vis[E.v])
    				{
    					vis[E.v]=1;
    					used[E.v]++;
    					if(used[E.v]>n)
    					return false;
    					q.push(E.v);
    				}
    			}
    		}
    	}
    	return true;
    }
    int main()
    {
    	while(scanf("%d%d",&n,&m)!=EOF)
    	{
    		init();
    		getmap();
    		if(SPFA())
    		cout<<-dis[0]<<endl;
    		else
    		cout<<"Bad Estimations"<<endl;
    	}
    	return 0;
    }


    
    

  • 相关阅读:
    wode.
    python中迭代器和生成器。
    Embeded linux 之 UBIFS文件系统
    Windows下Git安装和使用
    套接字 之 windows与linux 差异
    Embeded linux之RTL8188EU/RTL8188ETV使用
    嵌入式Linux之“+”版本问题
    Uboot之net
    Embeded linux之reboot
    Embeded linux之cifs文件系统
  • 原文地址:https://www.cnblogs.com/playboy307/p/5273548.html
Copyright © 2011-2022 走看看