zoukankan      html  css  js  c++  java
  • POJ3292(素数筛选)

    Semi-prime H-numbers
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 8706   Accepted: 3809

    Description

    This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

    An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

    As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

    For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

    Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

    Input

    Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

    Output

    For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

    Sample Input

    21 
    85
    789
    0

    Sample Output

    21 0
    85 5
    789 62
    思路:注意H数的域是模4余1的数。如9是H数,虽然在自然数范围内9不是素数但是在H数域内9是H-prime。
    #include <iostream>
    #include <string.h>
    using namespace std;
    const int MAXN=1000005;
    bool isHprime[MAXN];
    int Hprime[MAXN],top;
    int h[MAXN];
    void sieve()
    {
        memset(isHprime,true,sizeof(isHprime));
        for(int i=5;i<MAXN;i+=4)
        {
            if(isHprime[i])
            {
                Hprime[top++]=i;
                for(int j=i+i;j<MAXN;j+=i)
                {
                    if((j-1)%4==0)
                    {
                        isHprime[j]=false;
                    }
                }
            }
        }
        for(int i=0;i<top;i++)
        {
            if(Hprime[i]>10000)    break;
            for(int j=i;j<top;j++)
            {
                int mul=Hprime[i]*Hprime[j];
                if(mul>=MAXN)
                {
                    break;
                }
                h[mul]=1;
            }
        }
        for(int i=1;i<MAXN;i++)
        {
            h[i]+=h[i-1];
        }
    }
    int main()
    {
        sieve();
        int n;
        while(cin>>n&&n!=0)
        {
            cout<<n<<" "<<h[n]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    ThinkPHP模版验证要注意的地方
    js关闭子页面刷新父页面
    js替换字符指定字符方法
    Ubuntu安装后的一些配置
    Docker入门
    RabbitMQ 基本概念和使用
    JAX-WS注解
    Linux 常用命令
    ubuntu16.04 搭建 Mysql服务器
    ubuntu 安装 Tomcat
  • 原文地址:https://www.cnblogs.com/program-ccc/p/5682470.html
Copyright © 2011-2022 走看看