zoukankan      html  css  js  c++  java
  • POJ 3991 括号匹配问题(贪心)

    I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one. 
    You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows: 
    1. An empty string is stable. 
    2. If S is stable, then {S} is also stable. 
    3. If S and T are both stable, then ST (the concatenation of the two) is also stable. 
    All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{. 
    The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa. 

    InputYour program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length. 
    The last line of the input is made of one or more ’-’ (minus signs.) 

    OutputFor each test case, print the following line: 
    k. N 
    Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one. 
    Note: There is a blank space before N. 
    Sample Input

    }{
    {}{}{}
    {{{}
    ---

    Sample Output

    1. 2
    2. 0
    3. 1

    题意:问需要改变几个括号才能使字符串是stable

    思路:对左括号计数;遇到右括号:如果有左括号则配对一个,左括号数减一;如果没有左括号,那么右括号一定是需要修改的

    代码:
    import java.util.Scanner;
    public class Main {
          public static void main(String[] args) {
               Scanner scan=new Scanner(System.in);
               int k=1;
               while(scan.hasNext()){
                    String s=scan.next();
                    if(s.charAt(0)=='-') break;
                    int len=s.length();
                    int cnt=0,c=0;//cnt需要改变的数量;c为{的数量
                    for(int i=0;i<len;i++){
                          if(s.charAt(i)=='{'){
                                c++;
                          }
                          else{
                               if(c>0) c--;
                               else{
                                     c++; cnt++;
                               }
                          }
                    }
                    cnt+=c/2;
                    System.out.println((k++)+". "+cnt);
               }
        }
    }
  • 相关阅读:
    关于MySQL错误 2005
    Eclipse如何导入第三方jar包
    Codeforces Round #377 (Div. 2) D. Exams
    18110 Koishi's travel, Satori's travel
    用Java做的类似皇家守卫战的游戏
    Notepad++如何编译、运行Java
    Codeforces Round #341 (Div. 2)--C. Wet Shark and Flowers
    hdu 2120 Ice_cream's world I
    FZU 1851 组合数
    HUST 1599 Multiple
  • 原文地址:https://www.cnblogs.com/qdu-lkc/p/12193008.html
Copyright © 2011-2022 走看看