zoukankan      html  css  js  c++  java
  • HDU1548 奇怪的电梯(bfs求最少)

    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist. 
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

    InputThe input consists of several test cases.,Each test case contains two lines. 
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
    A single 0 indicate the end of the input.OutputFor each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".Sample Input

    5 1 5
    3 3 1 2 5
    0

    Sample Output

    3

    用vis[]数组记录已经走过哪层

    广搜注意事项:对于有多个输入

    1.vis数组一定要初始化
    2.队列一定要清空
    3.初始点一定要标记vis=true
    4.分清楚到底几个方向,是4个方向,还是6个方向,for(int i=0;i<4||i<6;i++)
    5.遍历完每种情况一定要入队

    代码:
    import java.util.*;
    class Node{
            int x;
            long times;
            public Node(int x,long times){
                    this.x=x;
                    this.times=times;
            }
     }
    public class Main{
            static ArrayDeque<Node> q=new ArrayDeque<Node>();
            static final int N=205;
            static int val[]=new int[N];
            static boolean vis[]=new boolean[N];
            static int n,a,b;
            static long bfs(){
                    while(!q.isEmpty()) q.poll();
                    Arrays.fill(vis, false);
                    vis[a]=true;;
                    q.offer(new Node(a,0));
                    while(!q.isEmpty()){
                            Node t=q.poll();
                            if(t.x==b) return t.times;
                            for(int i=-1;i<=1;i+=2){
                                    int xx=t.x+i*val[t.x];
                                    if(xx<=0||xx>n ||vis[xx]) continue;
                                    vis[xx]=true;
                                    q.offer(new Node(xx,t.times+1));
                            }
                    }
                    return -1;
            }
            public static void main(String[] args) {
                    Scanner scan=new Scanner(System.in);
                    while(scan.hasNext()){
                            n=scan.nextInt();
                            if(n==0) break;
                            a=scan.nextInt();
                            b=scan.nextInt();
                            for(int i=1;i<=n;i++) val[i]=scan.nextInt();
                            System.out.println(bfs());
                    }
            }
    }
  • 相关阅读:
    在VC中读写ini配置文件
    fangwen
    背景建模与前景检测
    前景检测算法_3(GMM)
    目标检测中背景建模方法 [转]
    2018目标
    Idhttp Get方法
    二、酷狗 歌词下载
    一、酷狗 歌词搜索 Indy TIdhttp
    酷狗.Krc加密歌词解析
  • 原文地址:https://www.cnblogs.com/qdu-lkc/p/12247821.html
Copyright © 2011-2022 走看看