zoukankan      html  css  js  c++  java
  • PATA 1009. Product of Polynomials (25)

    1009. Product of Polynomials (25)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    This time, you are supposed to find A*B where A and B are two polynomials.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

     

    Output Specification:

    For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

    Sample Input
    2 1 2.4 0 3.2
    2 2 1.5 1 0.5
    
    Sample Output

    3 3 3.6 2 6.0 1 1.6

    #include <cstdio>
    const int maxn = 2001;
    int main()
    {
    	double coef[maxn]={0};
    	double ans[maxn]={0};  //原来直接用coef[]存储计算后的系数,导致出现问题,应另用一个ans保存 。 
    	int k1,k2,i,j,ex,k3=0;
    	double co;
    	scanf("%d",&k1);
    	for(i = 0;i < k1; i++)
    	{
    		scanf("%d%lf",&ex,&co);
    		coef[ex] = co;
    	}
    	scanf("%d",&k2); 
    	for(i = 0;i < k2; i++)
    	{
    		scanf("%d%lf",&ex,&co);
    		for(j = 0;j <1001;j++)
    		{
    			ans[ex+j] += co*coef[j];		
    		}
    	}
    	for(i = 0;i < maxn; i++)
    	{
    		if(ans[i] != 0.0) k3++;
    	}
    	printf("%d",k3);
    	
    	for(i = maxn-1;i >= 0; i--)
    	{
    		if(ans[i]!=0.0){
    			printf(" %d %.1lf",i,ans[i]);
    		}
    	}
    	return 0;	
    }
  • 相关阅读:
    Minimum Inversion Number(归并排序)
    Ultra-QuickSort(归并排序)
    求逆序数(归并排序)
    Hat's Fibonacci(大数,好)
    Baskets of Gold Coins
    Permutation Recovery(模拟)
    反恐训练营(LCS)
    I Hate It(线段树)
    敌兵布阵
    Django报错:提交表单报错---RuntimeError: You called this URL via POST, but the URL doesn’t end in a slash and you have APPEND_SLASH set.
  • 原文地址:https://www.cnblogs.com/qiangz/p/8447207.html
Copyright © 2011-2022 走看看