zoukankan      html  css  js  c++  java
  • HDU 1158 Employment Planning (DP)

    Employment Planning

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2110    Accepted Submission(s): 832


    Problem Description
    A project manager wants to determine the number of the workers needed in every month. He does know the minimal number of the workers needed in each month. When he hires or fires a worker, there will be some extra cost. Once a worker is hired, he will get the salary even if he is not working. The manager knows the costs of hiring a worker, firing a worker, and the salary of a worker. Then the manager will confront such a problem: how many workers he will hire or fire each month in order to keep the lowest total cost of the project. 
     
    Input
    The input may contain several data sets. Each data set contains three lines. First line contains the months of the project planed to use which is no more than 12. The second line contains the cost of hiring a worker, the amount of the salary, the cost of firing a worker. The third line contains several numbers, which represent the minimal number of the workers needed each month. The input is terminated by line containing a single '0'.
     
    Output
    The output contains one line. The minimal total cost of the project.
     
    Sample Input
    3
    4 5 6
    10 9 11
    0
     
    Sample Output
    199
     
     
    dp[i][j]表示前i个月最后一个月的总人数为j所花的最小费用
     
     
    状态移动方程:dp[i][j] = min{dp[i-1][k] + cost[i][j]},其中cost[i][j]是第i月的花费,
    1~当k<=j时,第i个月请了人所以cost[i][j] = j*salary + (j-k)*hire
    2~当k>j时,第i个月炒了人,所以cost[i][j] = j*salary + (k-j)*fire
     
    输入时记录了最多需要的人数。
     
    因为他给的是每个月最少需要的人数,所以for(该月需要的最少人数——max_people)而不是for(1——该月需要的最少人数)
     
    直接初始化第一个月。



    View Code
    #include <set>
    #include <map>
    #include <list>
    #include <cmath>
    #include <ctime>
    #include <deque>
    #include <queue>
    #include <stack>
    #include <cstdio>
    #include <string>
    #include <vector>
    #include <cctype>
    #include <cstring>
    #include <sstream>
    #include <fstream>
    #include <cstdlib>
    #include <cassert>
    #include <iostream>
    #include <algorithm>

    using namespace std;
    //Constant Declaration
    /*
    --------------------------*/
    //#define LL long long
    #define LL __int64
    const int M=10000;
    const int INF=1<<30;
    const double EPS = 1e-11;
    const double PI = acos(-1.0);
    /*--------------------------*/
    // some essential funtion
    /*
    ----------------------------------*/
    void Swap(int &a,int &b){ int t=a;a=b;b=t; }
    int Max(int a,int b){ return a>b?a:b; }
    int Min(int a,int b){ return a<b?a:b; }
    int Gcd(int a,int b){ while(b){b ^= a ^=b ^= a %= b;} return a; }
    /*----------------------------------*/
    //for (i = 0; i < n; i++)
    /*
    ----------------------------------*/


    int dp[15][M];
    int people[15];
    int main()
    {
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    //int t, case1 = 0;
    //scanf("%d", &t);
    int n, m;
    int i, j, k;
    while (~scanf("%d", &n), n)
    {
    int hire, fire, salary;
    scanf("%d%d%d", &hire, &salary, &fire);
    int max_people = 0;
    for (i = 1; i <= n; i++)
    {
    scanf("%d", &people[i]);
    if (max_people < people[i])
    {
    max_people = people[i];
    }
    }
    //memset(dp, 0, sizeof(dp));不需要
    for (i = people[1]; i <= max_people; i++)//初始化第一个月。
    {
    dp[1][i] = i*salary + i*hire;
    }

    for (i = 2; i <= n; i++)
    {
    for (j = people[i]; j <= max_people; j++)
    {
    int minn = INF;//有了这个前面就不需要用O(n^2)初始化dp了。
    for (k = people[i-1]; k<= max_people; k++)
    {
    if (minn > dp[i-1][k] + (j>=k?(j*salary+hire*(j-k)):(j*salary+fire*(k-j))))
    {
    minn = dp[i-1][k] + (j>=k?(j*salary+hire*(j-k)):(j*salary+fire*(k-j)));
    }
    }
    dp[i][j] = minn;
    }
    }


    int min = INF;
    for (j = people[n]; j <= max_people; j++)
    {
    if (min > dp[n][j])
    {
    min = dp[n][j];
    }
    }
    printf("%d\n", min);
    }


    return 0;
    }


  • 相关阅读:
    服务器负载均衡的基本功能和实现原理
    几种负载均衡技术的实现
    Postman-CI集成Jenkins
    Postman-进阶
    Postman-简单使用
    chrome安装插件,安装Postman
    关于angularjs dom渲染结束再执行的问题
    Protractor(angular定制的e2e)的简易入门
    关于ng-router嵌套使用和总结
    scss使用后的简单入门总结
  • 原文地址:https://www.cnblogs.com/qiufeihai/p/2400273.html
Copyright © 2011-2022 走看看