Problem B
Time Limit : 1000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 122 Accepted Submission(s) : 12
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".
Input
each test case contains two numbers A and B.
Output
for each case, if A is equal to B, you should print "YES", or print "NO".
Sample Input
1 2 2 2 3 3 4 3
Sample Output
NO YES YES NO
刚开始晕了,尽然会用BigInteger,后来用BigDecimal轻松搞定,不过,据说用c或者c++有点麻烦。。。。
AC代码:
import java.math.BigDecimal;
import java.util.Scanner;
public class hdu2504{
public static void main(String[] args) {
Scanner cin =new Scanner (System.in);
while(cin.hasNext()){
BigDecimal a = cin.nextBigDecimal();
BigDecimal b = cin.nextBigDecimal();
if(a.compareTo(b)==0){
System.out.println("YES");
}
else{
System.out.println("NO");
}
}
}
}