zoukankan      html  css  js  c++  java
  • next的意义 poj 2752

    Seek the Name, Seek the Fame
     
    http://poj.org/problem?id=2752
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions:28387   Accepted: 14734

    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

    Step1. Connect the father's name and the mother's name, to a new string S. 
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    #include<cstdio>
    #include<cstring>
    const int maxn=4e5+3;
    char str[maxn];
    int next[maxn],ans[maxn];
    int len;
    void getnext(){
        int k=-1,j=0;
        next[0]=-1;
        while(j<len){
            if(k==-1||str[k]==str[j]){
                k++;
                j++;
                next[j]=k;
            }else{
                k=next[k];
            }
        }
    }
    int main(){
        while(~scanf("%s",str)){
            len=strlen(str);
            getnext();
            int cnt=0,j=len;
            while(j!=0){
                ans[cnt++]=j;
                j=next[j];//相同前后缀的相同前后缀为原字符串的相同前后缀;也就是next内的数;
            }
            for(int i=cnt-1;i>=0;i--){
                printf("%d%c",ans[i],i==0?'
    ':' ');
            }
        }
        return 0;
    }
  • 相关阅读:
    Jquery尺寸
    Jquery 位置
    c#编码规范
    手机即时通信文章列表
    缺陷跟踪系统BugTracker。 以下对使用
    用正则表达式来匹配图片标签
    mvc 分页
    Asp.Net MVC4网站中自定义AuthorizeAttribute
    asp.net mvc4 身份验证问题无法绕过内置的Membership/Role机制
    HDU4712Hamming Distance随机化算法
  • 原文地址:https://www.cnblogs.com/qqshiacm/p/11586740.html
Copyright © 2011-2022 走看看