zoukankan      html  css  js  c++  java
  • Codeforces Gym 100418A A

    A - A+-B
    Time Limit: 20 Sec

    Memory Limit: 256 MB

    题目连接

    http://acm.hust.edu.cn/vjudge/contest/view.action?cid=86686#problem/A

    Description

    You are given the integer numbers A and B. Output A + B or A - B.

    Input

    The first line contains two numbers AB separeted by a single space ( - 263 ≤ A, B < 263).

    Output

    Output one integer number: A + B or A - B.

    Sample Input

    15 27

    Sample Output

    42

    HINT

    题意

    给你a,b,让你输出a+b或者a-b,需要保证输出的值是一个integer

    题解

    高精度一下,然后输出最小的就好了

    用的JAVA = =

    代码:

    import java.util.*;   
    import java.io.*;   
    import java.math.*;     
    public class Main  
    {  
        public static void main(String [] args)  
        {  
            Scanner in = new Scanner(System.in);  
            BigInteger a = in.nextBigInteger();  
            BigInteger b = in.nextBigInteger();  
            BigInteger c = a.add(b);
            BigInteger d = a.subtract(b);
            BigInteger f;
            BigInteger kiss;
            kiss = BigInteger.valueOf(0);
            f = BigInteger.valueOf(-1);
            int test = d.compareTo(kiss);
            if( test == -1 )
                d = d.multiply(f);
            test = c.compareTo(d);
            if( test == 1 )
                System.out.println(a.subtract(b));
            else
                System.out.println(a.add(b));
        }  
    }  
  • 相关阅读:
    "Key Violation" with ClientDataSet
    c# 的关键字 params,out,ref
    eval && JSON.parse
    json2.js
    C#中的索引器
    call , apply , caller , callee
    iphone&ipad图标去除高亮的光圈效果
    调用系统路线导航
    调科大讯飞出现的问题
    得到汉字首字母在表中的顺序位置
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4711646.html
Copyright © 2011-2022 走看看