zoukankan      html  css  js  c++  java
  • Codeforces Gym 100418A A

    A - A+-B
    Time Limit: 20 Sec

    Memory Limit: 256 MB

    题目连接

    http://acm.hust.edu.cn/vjudge/contest/view.action?cid=86686#problem/A

    Description

    You are given the integer numbers A and B. Output A + B or A - B.

    Input

    The first line contains two numbers AB separeted by a single space ( - 263 ≤ A, B < 263).

    Output

    Output one integer number: A + B or A - B.

    Sample Input

    15 27

    Sample Output

    42

    HINT

    题意

    给你a,b,让你输出a+b或者a-b,需要保证输出的值是一个integer

    题解

    高精度一下,然后输出最小的就好了

    用的JAVA = =

    代码:

    import java.util.*;   
    import java.io.*;   
    import java.math.*;     
    public class Main  
    {  
        public static void main(String [] args)  
        {  
            Scanner in = new Scanner(System.in);  
            BigInteger a = in.nextBigInteger();  
            BigInteger b = in.nextBigInteger();  
            BigInteger c = a.add(b);
            BigInteger d = a.subtract(b);
            BigInteger f;
            BigInteger kiss;
            kiss = BigInteger.valueOf(0);
            f = BigInteger.valueOf(-1);
            int test = d.compareTo(kiss);
            if( test == -1 )
                d = d.multiply(f);
            test = c.compareTo(d);
            if( test == 1 )
                System.out.println(a.subtract(b));
            else
                System.out.println(a.add(b));
        }  
    }  
  • 相关阅读:
    python冲刺(5)列表声称式
    python冲刺(4)切片 等
    python冲刺(3)函数 等
    python冲刺(2)
    python冲刺(1)
    redis初步(1)
    php连接Oracle的时候遇到的编码集问题
    redis初步
    php 命名空间
    指向字符数组的指针与指向整型数组的指针
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4711646.html
Copyright © 2011-2022 走看看