zoukankan      html  css  js  c++  java
  • HDU 5642 King's Order 动态规划

    King's Order

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5642

    Description

    After the king's speech , everyone is encouraged. But the war is not over. The king needs to give orders from time to time. But sometimes he can not speak things well. So in his order there are some ones like this: "Let the group-p-p three come to me". As you can see letter 'p' repeats for 3 times. Poor king!

    Now , it is war time , because of the spies from enemies , sometimes it is pretty hard for the general to tell which orders come from the king. But fortunately the general know how the king speaks: the king never repeats a letter for more than 3 times continually .And only this kind of order is legal. For example , the order: "Let the group-p-p-p three come to me" can never come from the king. While the order:" Let the group-p three come to me" is a legal statement.

    The general wants to know how many legal orders that has the length of n

    To make it simple , only lower case English Letters can appear in king's order , and please output the answer modulo 1000000007

    We regard two strings are the same if and only if each charactor is the same place of these two strings are the same.

    Input

    The first line contains a number T(T≤10)——The number of the testcases.

    For each testcase, the first line and the only line contains a positive number n(n≤2000).

    Output

    For each testcase, print a single number as the answer.

    Sample Input

    2
    2
    4

    Sample Output

    676
    456950

    hint:
    All the order that has length 2 are legal. So the answer is 26*26.

    For the order that has length 4. The illegal order are : "aaaa" , "bbbb"…….."zzzz" 26 orders in total. So the answer for n == 4 is 26^4-26 = 456950

    hint:
    For the first testcase you can divide the into one cake of (2 imes2) , 2 cakes of (1 imes 1)

    Hint

    题意

    问你长度为n的字符串,只含有小写字母。

    没有超过3个连续相同。

    问你这个字符串一共有多少种。

    题解:

    dp[i][j]表示第i个位置,当前连续长度为j的方案数。

    然后转移就好了。

    可以直接预处理出来。

    代码

    #include<stdio.h>
    #include<algorithm>
    #include<iostream>
    #include<math.h>
    #include<cstring>
    using namespace std;
    
    const int mod = 1e9+7;
    const int maxn = 2000+7;
    
    long long dp[maxn][4];
    void pre()
    {
        dp[1][1]=26;
        for(int i=1;i<=2000;i++)
        {
            for(int j=1;j<=3;j++)
            {
                if(dp[i][j])
                {
                    if(j!=3)dp[i+1][j+1]=(dp[i][j]+dp[i+1][j+1])%mod;
                    dp[i+1][1]=(dp[i+1][1]+dp[i][j]*25)%mod;
                }
            }
        }
    }
    void solve()
    {
        int n;scanf("%d",&n);
        long long ans = 0;
        for(int i=1;i<=3;i++)
            ans=(ans+dp[n][i])%mod;
        cout<<ans<<endl;
    }
    int main()
    {
        int t;scanf("%d",&t);
        pre();
        while(t--)solve();
        return 0;
    }
  • 相关阅读:
    简单bb两句
    P2894 [USACO08FEB]Hotel G
    文艺平衡树
    CS184.1X 计算机图形学导论作业1
    C++ Primer Plus章节编程练习(第五章)
    C++ Primer Plus章节编程练习(第六章)
    CS184.1X 计算机图形学导论作业0
    C++ Primer Plus章节编程练习(第四章)
    计算机图形学之光栅图形学算法
    Codeforces 980B
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5270322.html
Copyright © 2011-2022 走看看