zoukankan      html  css  js  c++  java
  • HDU 5344 MZL's xor 水题

    MZL's xor

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5344

    Description

    MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1≤i,j≤n)
    The xor of an array B is defined as B1 xor B2...xor Bn

    Input

    Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
    Each test case contains four integers:n,m,z,l
    A1=0,Ai=(Ai−1∗m+z) mod l
    1≤m,z,l≤5∗105,n=5∗105

    Output

    For every test.print the answer.

    Sample Input

    2
    3 5 5 7
    6 8 8 9

    Sample Output

    14
    16

    Hint

    题意

    求所有的Ai+Aj的异或值,1<=i,j<=n

    题解:

    ai+aj这尼玛不是FFT嘛

    赶紧莽一波,然后TLE成傻逼了

    然后队友提醒我了,(ai+aj)^(aj+ai)=0,其实这是一道智障题……

    当时整个人都懵逼了

    代码

    #include<bits/stdc++.h>
    using namespace std;
    
    int n,m,z,l;
    void solve()
    {
        scanf("%d%d%d%d",&n,&m,&z,&l);
        long long ans = 0;
        long long pre = 0;
        for(int i=0;i<n;i++)
        {
            ans^=2LL*pre;
            pre = (1ll*pre*m+z)%l;
        }
        cout<<ans<<endl;
    }
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)solve();
        return 0;
    }
  • 相关阅读:
    在Eclipse中设置中文JavaDOC
    买车,给点建议和意见
    父亲节
    JSP文件上传

    昨天我生日
    换皮了
    西安夕阳
    WinForms中只能输入数字的文本框
    使用GoogleCode SVN服务
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5449528.html
Copyright © 2011-2022 走看看