zoukankan      html  css  js  c++  java
  • HDU 5682 zxa and leaf 二分 树形dp

    zxa and leaf

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5682

    Description

    zxa have an unrooted tree with n nodes, including (n−1) undirected edges, whose nodes are numbered from 1 to n. The degree of each node is defined as the number of the edges connected to it, and each node whose degree is 1 is defined as the leaf node of the tree.

    zxa wanna set each node's beautiful level, which must be a positive integer. His unrooted tree has m(1≤m≤n) leaf nodes, k(1≤k≤m) leaf nodes of which have already been setted their beautiful levels, so that zxa only needs to set the other nodes' beautiful levels.

    zxa is interested to know, assuming that the ugly level of each edge is defined as the absolute difference of the beautiful levels between two nodes connected by this edge, and the ugly level of the tree is the maximum of the ugly levels of all the edges on this tree, then what is the minimum possible ugly level of the tree, can you help him?

    Input

    The first line contains an positive integer T, represents there are T test cases.

    For each test case:

    The first line contains two positive integers n and k, represent the tree has n nodes, k leaf nodes of which have already been setted their beautiful levels.

    The next (n−1) lines, each line contains two distinct positive integers u and v, repersent there is an undirected edge between node u and node v.

    The next k lines, each lines contains two positive integers u and w, repersent node u is a leaf node, whose beautiful level is w.

    There is a blank between each integer with no other extra space in one line.

    It's guaranteed that the input edges constitute a tree.

    1≤T≤10,2≤n≤5⋅104,1≤k≤n,1≤u,v≤n,1≤w≤109

    Output

    For each test case, output in one line a non-negative integer, repersents the minimum possible ugly level of the tree.

    Sample Input

    2
    3 2
    1 2
    1 3
    2 4
    3 9
    6 2
    1 2
    1 3
    1 4
    2 5
    2 6
    3 6
    5 9

    Sample Output

    3
    1

    Hint

    题意

    zxa有一棵含有(n)个节点的无根树,包含((n-1))条无向边,点从(1)(n)编号,定义每个点的度数为与这个点相连的边的数量,度数为(1)的节点被称作这棵树的叶子节点。

    zxa想给每个节点设置它的好看度,好看度必须为正整数。他的无根树有(m(1leq mleq n))个叶子节点,其中的(k(1leq kleq m))个叶子节点的好看度已经确定,zxa只需要设置其他节点的好看度。

    zxa很好奇,如果令每条边的难看度是这条边所连接的两个节点的好看度差值的绝对值,整棵树的难看度是所有边的难看度中的最大值,那么这棵树的难看度最小是多少,你能帮助他吗?

    题解:

    二分答案之后,树形dp去跑每个节点的取值范围就好了

    如果范围是允许的,那就可以直接返回true

    否则就返回false

    挺好的一道题

    代码

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn = 5e4+6;
    int w[maxn],n,k,l[maxn],r[maxn],vis[maxn];
    vector<int>E[maxn];
    int dfsl(int x,int d)
    {
        for(int i=0;i<E[x].size();i++)
        {
            if(!vis[E[x][i]])
            {
                vis[E[x][i]]=1;
                l[x]=max(l[x],dfsl(E[x][i],d));
            }
        }
        return l[x]-d;
    }
    int dfsr(int x,int d)
    {
    
        for(int i=0;i<E[x].size();i++)
        {
    
            if(!vis[E[x][i]])
            {
                vis[E[x][i]]=1;
                r[x]=min(r[x],dfsr(E[x][i],d));
            }
        }
        return r[x]+d;
    }
    bool check(int mid)
    {
        for(int i=1;i<=n;i++)
        if(w[i])l[i]=r[i]=w[i];
        else l[i]=0,r[i]=1e9;
        memset(vis,0,sizeof(vis));
        dfsl(1,mid);
        memset(vis,0,sizeof(vis));
        dfsr(1,mid);
        for(int i=1;i<=n;i++)
            if(r[i]<l[i])return false;
        return true;
    }
    void solve()
    {
        for(int i=0;i<maxn;i++)E[i].clear();
        for(int i=0;i<maxn;i++)w[i]=0;
        scanf("%d%d",&n,&k);
        for(int i=1;i<n;i++)
        {
            int x,y;scanf("%d%d",&x,&y);
            E[x].push_back(y);
            E[y].push_back(x);
        }
        for(int i=1;i<=k;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            w[x]=y;
        }
        int L=0,R=1e9,ans=1e9;
        while(L<=R)
        {
            int mid=(L+R)/2;
            if(check(mid))R=mid-1,ans=mid;
            else L=mid+1;
        }
        cout<<ans<<endl;
    }
    int main()
    {
        int t;scanf("%d",&t);
        while(t--)solve();
        return 0;
    }
  • 相关阅读:
    双系统下,Windows如何正确删除Linux系统
    关于通过adb启动Activity、activity、service以及发送broadcast的命令
    Eclipse常用快捷键集合
    关于“学习Linux用什么系统”的解答
    关于设置android:imeOptions属性无效的解决办法
    Android XML文件布局各个属性详解
    Android开发:文本控件详解——EditText(一)基本属性
    Android开发:UI相关(一)自定义样式资源
    Android开发:文本控件详解——TextView(一)基本属性
    Android开发:Android Studio开发环境配置
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5495791.html
Copyright © 2011-2022 走看看