zoukankan      html  css  js  c++  java
  • 九度OJ

    题目描述:

    A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

    There is exactly one node, called the root, to which no directed edges point. 
    Every node except the root has exactly one edge pointing to it. 
    There is a unique sequence of directed edges from the root to each node. 
    For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


    In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

    输入:

    The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero and less than 10000.

    输出:

    For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

    样例输入:
    6 8  5 3  5 2  6 4
    5 6  0 0
    
    8 1  7 3  6 2  8 9  7 5
    7 4  7 8  7 6  0 0
    
    3 8  6 8  6 4
    5 3  5 6  5 2  0 0
    -1 -1
    样例输出:
    Case 1 is a tree.
    Case 2 is a tree.
    Case 3 is not a tree.
    来源:
    2012年北京大学计算机研究生机试真题
    #include <iostream>
    using namespace std;
    
    const int N = 10000;
    
    int set[N];
    bool visited[N];
    
    int find(int t) {
        if (set[t] == t)
            return t;
        return set[t] = find(set[t]);
    }
    
    int main() {
        int Case = 0, a, b;
        while (cin >> a >> b && a >= 0 && b >= 0) {
            bool flag = true;
            int edge = 0, node = 0;
            Case++;
            for (int i = 0; i < N; i++) {
                set[i] = i;
                visited[i] = false;
            }
            while (a != 0 && b != 0) {
                if (find(b) == b && find(a) != b)
                    set[b] = a;
                else
                    flag = false;
                if (!visited[a]) {
                    visited[a] = true;
                    node++;
                }
                if (!visited[b]) {
                    visited[b] = true;
                    node++;
                }
                edge++;
                cin >> a >> b;
            }
            if (node != 0 && node != edge + 1)
                flag = false;
            if (flag)
                cout << "Case " << Case << " is a tree." << endl;
            else
                cout << "Case " << Case << " is not a tree." << endl;
        }
    }
    

      

  • 相关阅读:
    crontab 实际的应用
    php 求素数的二种方法
    linux svn配置hooks
    php执行超时(nginx,linux环境)
    php使用strpos,strstr,strchr注意啦,若是数字查找则会当成ASCII码处理
    php 处理大文件方法 SplFileObject
    高德地图定位
    jquery 实现鼠标点击div盒子移动功能
    centos 安装php缓存 apc或zend-opcode
    phpQuery用法总结
  • 原文地址:https://www.cnblogs.com/qwertWZ/p/3565827.html
Copyright © 2011-2022 走看看