zoukankan      html  css  js  c++  java
  • poj 2632, 模拟

    Crashing Robots
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 7004   Accepted: 3059

    Description

    In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
    A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

    Input

    The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
    The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
    Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

    Figure 1: The starting positions of the robots in the sample warehouse

    Finally there are M lines, giving the instructions in sequential order.
    An instruction has the following format:
    < robot #> < action> < repeat>
    Where is one of
    • L: turn left 90 degrees,
    • R: turn right 90 degrees, or
    • F: move forward one meter,

    and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

    Output

    Output one line for each test case:
    • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
    • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
    • OK, if no crashing occurs.

    Only the first crash is to be reported.

    Sample Input

    4
    5 4
    2 2
    1 1 E
    5 4 W
    1 F 7
    2 F 7
    5 4
    2 4
    1 1 E
    5 4 W
    1 F 3
    2 F 1
    1 L 1
    1 F 3
    5 4
    2 2
    1 1 E
    5 4 W
    1 L 96
    1 F 2
    5 4
    2 3
    1 1 E
    5 4 W
    1 F 4
    1 L 1
    1 F 20

    Sample Output

    Robot 1 crashes into the wall
    Robot 1 crashes into robot 2
    OK
    Robot 1 crashes into robot 2

    Source

     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<string>
    #include<cmath>
    #include<vector>
    #include<cstdlib>
    #include<algorithm>
    
    using namespace std;
    
    #define LL long long
    #define ULL unsigned long long
    #define UINT unsigned int
    #define MAX_INT 0x7fffffff
    #define MAX_LL 0x7fffffffffffffff
    #define MAX(X,Y) ((X) > (Y) ? (X) : (Y))
    #define MIN(X,Y) ((X) < (Y) ? (X) : (Y))
    
    #define MAXN 111
    
    int g[MAXN][MAXN];
    int C,R,n,m;
    
    struct rob{
        int x, y;
        int d;
    }ro[MAXN];
    
    const int dr[]={0, 1, 0, -1},
              dc[]={1, 0, -1, 0};
    int dir[333];
    
    
    int ins(int ri, char act, int rep, int &tt){
        int i;
        int &x=ro[ri].x, &y=ro[ri].y, &d=ro[ri].d;
        if(act=='L' || act=='R'){
            rep%=4;
            int it=(act == 'L' ? -1 : 1);
            for(i=0; i<rep; i++)
                d=(d+it+4)%4;
        }
        else{
            if(rep) g[x][y]=0;
            for(i=0; i<rep; i++){
                x+=dr[d];       y+=dc[d];
                if(g[x][y]==-1) return 1;
                else if(g[x][y]){
                    tt=g[x][y];
                    return 2;
                }
            }
            g[x][y]=ri;
        }
        return 0;
    }
    
    void solve(){
        int i;
        int ans=0, tp, tt;
        for(i=0; i<m; i++){
            int r0, rep;
            char act;
            scanf(" %d %c %d", &r0, &act, &rep);
          //  cout<<r0<<' '<<act<<' '<<rep<<endl;
            if(ans) continue;
            tp=r0;
            ans=ins(r0, act, rep, tt);
        }
        if(!ans) cout<<"OK"<<endl;
        else{
            cout<<"Robot "<<tp;
            if(ans==1){
                cout<<" crashes into the wall"<<endl;
            }
            else cout<<" crashes into robot "<<tt<<endl;
        }
    }
    
    int main(){
        //freopen("C:\Users\Administrator\Desktop\in.txt","r",stdin);
        int kase;
        scanf(" %d", &kase);
        dir['N']=0;     dir['E']=1;     dir['S']=2;     dir['W']=3;
        while(kase--){
            int i;
            scanf(" %d %d", &R, &C);
            scanf(" %d %d", &n, &m);
            memset(g, 0, sizeof(g));
            for(i=0; i<=C+1; i++){
                g[R+1][i]=g[0][i]=-1;
            }
            for(i=0; i<=R+1; i++){
                g[i][0]=g[i][C+1]=-1;
            }
            for(i=1; i<=n; i++){
                int x, y;       char d;
                scanf(" %d %d %c", &x, &y, &d);
                //cout<<x<<' '<<y<<' '<<d<<endl;
                ro[i]=(rob){x, y, dir[d]};
                g[x][y]=i;
            }
            solve();
        }
        return 0;
    }
    
  • 相关阅读:
    SQL_50题
    Java多线程之冰山一角
    概览
    Selector
    集群配置
    redis config
    分布式、集群
    redis相关技术总结
    redis scan扫描
    redis 单线程 多路io复用
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3412860.html
Copyright © 2011-2022 走看看