zoukankan      html  css  js  c++  java
  • uva10010 Where's Waldorf?

    Where's Waldorf?

    Given a m by n grid of letters, (

    $1 \leq m,n \leq 20$), and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e.  upper and lower case letters are to be treated as the same).  The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.

    Input

    The input begins with a single positive integer on a line by itself indicating  the number of the cases following, each of them as described below.  This line is followed by a blank line, and there is also a blank line between  two consecutive inputs.

    The input begins with a pair of integers, m followed by n, $1 \leq
m,n \leq 50$in decimal notation on a single line.  The next m lines contain n letters each;  this is the grid of letters in which the words of the list must be found.  The letters in the grid may be in upper or lower case.  Following the grid of letters, another integerk appears on a line by itself ($1 \leq k \leq 20$).  The next klines of input contain the list of words to search for, one word per line.  These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).

    Output

    For each test case, the output must follow the description below.  The outputs of two consecutive cases will be separated by a blank line.

    For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output.  The integers must be separated by a single space.  The first integer is the line in the grid where the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line).  The second integer is the column in the grid where the first letter of the given word can be found (1 represents the leftmost column in the grid, and nrepresents the rightmost column in the grid).  If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which places the first letter of the word closest to the top of the grid).  If two or more words are uppermost, the output should correspond to the leftmost of these occurences.  All words can be found at least once in the grid.

    Sample Input

    1
    
    8 11
    abcDEFGhigg
    hEbkWalDork
    FtyAwaldORm
    FtsimrLqsrc
    byoArBeDeyv
    Klcbqwikomk
    strEBGadhrb
    yUiqlxcnBjf
    4
    Waldorf
    Bambi
    Betty
    Dagbert
    

    Sample Output

    2 5
    2 3
    1 2
    7 8
    
    源代码:搜索整个矩形,找出一个位置与给定的单词的首字母相同的位置,然后再以该位置为基础,判断八个方向上是否有满足要求的序列
    若有,则输出该位置,否则在判断下一个位置

    #include<iostream>

    #include<string>

    using namespace std;

    string str1[51];

    string str2;

    int direction[8][2]={{-1,-1},{-1,0},{-1,+1},{0,-1},{0,+1},{+1,-1},{+1,0},{+1,+1}};

    void findTheWord(int r,int c);

    bool compWord(int theN,int theJ,int theK);

    char toUp(char ch);

    int main()

    {

        //freopen("uva10010.txt","r",stdin);

        //freopen("uva10010.out","w",stdout);

        int n,m,i;

        int r,c;

        cin>>n;

        getline(cin,str1[0]);

        while(n--)

        {      

            cin>>r>>c;

            getline(cin,str1[0]);

            for(i=0;i<r;++i)

            {

                getline(cin,str1[i]);

            }

            cin>>m;

            while(m--)

            {

                cin>>str2;

                findTheWord(r,c);

            }

            if(n>0) cout<<endl;

            

        } 

        system("pause");

        return 0;

    }

     

    void findTheWord(int r,int c)

    {

    //找出单词所在的位置 

        bool flag=false;

        int j,k;

        for(j=0;j<r;++j)

        {

            for(k=0;k<c;++k)

            {

                if(toUp(str2[0])==toUp(str1[j][k]))

                {

                    int len=str2.length();

                    //接下来是判断八个方向上哪个会是相等的,八个方向是优顺序的 

                    if(j-len >= -1 && k-len >=-1)

                    {

                        if(compWord(0,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    //

                    if(j-len >= -1)

                    {

                        if(compWord(1,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    //

                    if(j-len >= -1 && k+len <c+1)

                    {

                        if(compWord(2,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    //

                    if(k-len >= -1)

                    {

                        if(compWord(3,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    //

                    if(k+len < c+1)

                    {

                        if(compWord(4,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    if(j+len < r+1 && k-len >= -1)

                    {

                        if(compWord(5,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    

                    if(j+len < r+1)

                    {

                        if(compWord(6,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    }

                    if(j+len < r+1 && k+len < c+1)

                    {

                        if(compWord(7,j,k))

                        {

                            cout<<j+1<<" "<<k+1<<endl;

                            flag=true;

                            break;

                        }

                    } 

                }

            }

            if(flag) break;

        }

    }

    bool compWord(int theN,int theJ,int theK)

    {

        int len=str2.length();

        for(int i=1;i<len;++i)

        {

            if(toUp(str2[i])!=toUp(str1[theJ+i*direction[theN][0]][theK+i*direction[theN][1]]))

                return false;

        }

        

        return true;

    }

    char toUp(char ch)

    {

        if(ch < 'a')

            return ch;

        else

            return ch-32;

    }

  • 相关阅读:
    【计算机世界】467- XOR — 神奇的按位运算符
    记 · 复习知识 · 偶遇好玩的知识点
    【CSS】466- 一行 CSS 代码搞定响应式布局
    【Web技术】465- 关于前端埋点统计方案思考
    【CSS】464- 5种 CSS 浮动和清除浮动的方法
    简单易懂的 React useState() Hook 指南(长文建议收藏)
    java中的四类八种
    线程
    异常
    Aspx Ajax 调用 C#函数处理数据
  • 原文地址:https://www.cnblogs.com/redlight/p/2350301.html
Copyright © 2011-2022 走看看