zoukankan      html  css  js  c++  java
  • hdu2579之BFS

    Dating with girls(2)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1470    Accepted Submission(s): 414

    Problem Description
    If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
    The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
    There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
     
    Input
    The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
    The next r line is the map’s description.
     
    Output
    For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
     
    Sample Input
    1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
     
    Sample Output
    7
    #include<iostream>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<string>
    #include<queue>
    #include<algorithm>
    #include<map>
    #include<iomanip>
    #define INF 99999999
    using namespace std;
    
    const int MAX=100+10;
    char Map[MAX][MAX];
    int mark[MAX][MAX][20];
    int n,m,k;
    int dir[4][2]={0,1,0,-1,1,0,-1,0};
    
    struct Node{
    	int x,y,time;
    	Node(){}
    	Node(int X,int Y,int Time):x(X),y(Y),time(Time){}
    }start;
    
    int BFS(int &flag){
    	queue<Node>q;
    	Node oq,next;
    	q.push(start);
    	mark[start.x][start.y][start.time%k]=flag;
    	while(!q.empty()){
    		oq=q.front();
    		q.pop();
    		for(int i=0;i<4;++i){
    			next=Node(oq.x+dir[i][0],oq.y+dir[i][1],oq.time+1);
    			if(next.x<0 || next.y<0 || next.x>=n || next.y>=m)continue;
    			if(mark[next.x][next.y][next.time%k] == flag)continue;
    			if(next.time%k != 0 && Map[next.x][next.y] == '#')continue;
    			mark[next.x][next.y][next.time%k]=flag;
    			if(Map[next.x][next.y] == 'G')return next.time;
    			q.push(next);
    		}
    	}
    	return -1;
    }
    
    int main(){
    	int num=0,t;
    	cin>>t;
    	while(t--){
    		cin>>n>>m>>k;
    		for(int i=0;i<n;++i)cin>>Map[i];
    		for(int i=0;i<n;++i){
    			for(int j=0;j<m;++j){
    				if(Map[i][j] == 'Y')start.x=i,start.y=j;
    			}
    		}
    		start.time=0;
    		int temp=BFS(++num);
    		if(temp != -1)cout<<temp<<endl;
    		else cout<<"Please give me another chance!"<<endl;
    	}
    	return 0;
    }



  • 相关阅读:
    atitit.交换机 汇聚上联、网络克隆和标准共享的原理与区别
    Atitit.数据库分区的设计 attilax  总结
    Atitit.数据库分区的设计 attilax  总结
    Atitit.常用分区api的attilax总结
    Atitit.常用分区api的attilax总结
    Atitit.  单列索引与多列索引 多个条件的查询原理与设计实现
    Atitit.  单列索引与多列索引 多个条件的查询原理与设计实现
    Atitit.sql where条件表达式的原理  attilax概括
    Atitit.sql where条件表达式的原理  attilax概括
    Atitit.分区对索引的影响 分区索引和全局索引 attilax总结
  • 原文地址:https://www.cnblogs.com/riskyer/p/3221825.html
Copyright © 2011-2022 走看看