zoukankan      html  css  js  c++  java
  • hdu 1022 Train Problem I

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 15980    Accepted Submission(s): 5931

    Problem Description
    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
     
    Input
    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
     
    Sample Input
    3 123 321 3 123 312
     
    Sample Output
    Yes. in in in out out out FINISH No. FINISH
    Hint
    Hint
    For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
     

    import java.util.LinkedList;
    import java.util.Scanner;
    import java.util.Stack;
    
    public class Main{//1004ջ
    	public static void main(String[] args) {
    		Scanner input=new Scanner(System.in);
    		while(input.hasNext()){
    			int n=input.nextInt();
    			String s1=input.next();
    			String s2=input.next();
    			char a1[]=s1.toCharArray();
    			char a2[]=s2.toCharArray();
    			Stack<Character> stack=new Stack<Character>();
    			LinkedList<String> list=new LinkedList<String>();
    			int j=0;
    			for(int i=0;i<s1.length();i++){
    				stack.add(a1[i]);
    				list.add("in");
    				while(!stack.isEmpty()){
    					if(stack.peek()==a2[j]){
    						list.add("out");
    						stack.pop();
    						j++;
    					}
    					else
    						break;
    				}
    			}
    			if(stack.isEmpty()){
    				System.out.println("Yes.");
    				for(String h:list)
    					System.out.println(h);
    				System.out.println("FINISH");
    			}
    			else{
    				System.out.println("No.");
    				System.out.println("FINISH");
    			}
    		}
    	}
    }



  • 相关阅读:
    CPU飙高,OOM排查?
    反射
    Mybatits
    spring 基础问题
    java中格式化数字0和#区别
    java中File对象的mkdir和mkdirs的区别
    java截取字符串几种方式
    java工厂模式
    Java获取文件路径的几种方式
    jxl生成excel时,增加批注和冻结窗口
  • 原文地址:https://www.cnblogs.com/riskyer/p/3235334.html
Copyright © 2011-2022 走看看