zoukankan      html  css  js  c++  java
  • 【PAT】1063. Set Similarity (25) 待改进

    Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

    Input Specification:

    Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

    Output Specification:

    For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

    Sample Input:
    3
    3 99 87 101
    4 87 101 5 87
    7 99 101 18 5 135 18 99
    2
    1 2
    1 3
    
    Sample Output:
    50.0%
    33.3%
    

    分析:两个集合共有的元素个数 / 两个集合合并后的元素个数.

    有一组超时,待改进:

    #include<iostream>
    #include<set>
    #include<vector>
    using namespace std;
    int main()
    {
    	int N;	
    	int i,count,j,t;
    	cin>>N;
    	vector< set<int> > vec(N);
    	for(i=0; i<N; i++){
    		scanf("%d",&count);
    		for(j=0; j<count; j++){
    			scanf("%d",&t);
    			vec[i].insert(t);
    		}
    	}
    	int request,a,b;
    	scanf("%d",&request);
    	for(i=0; i<request; i++){
    		scanf("%d %d",&a,&b);
    		set<int> temp_set;
    		set<int>::iterator it;
    		for(it = vec[a-1].begin(); it != vec[a-1].end(); it++){
    			temp_set.insert( *it );
    		}
    		for(it = vec[b-1].begin(); it != vec[b-1].end(); it++){
    			temp_set.insert( *it );
    		}
    		
    		printf( "%.1f",(float)( vec[a-1].size()+vec[b-1].size()-temp_set.size())*100/(float)(temp_set.size()) );
    		cout<<"%"<<endl;
    	}
    	return 0;
    }




  • 相关阅读:
    行列式学习笔记
    二项式反演学习笔记
    【AtCoder】ARC096(C
    【LOJ】#2127. 「HAOI2015」按位或
    [ACM] POJ 1218 THE DRUNK JAILER (关灯问题)
    lua的弱弱引用表
    西班牙式软件团队
    【DRP】採用dom4j完毕XML文件导入数据库
    基于Linux平台病毒Wirenet.c解析
    【剑指offer】异或去重
  • 原文地址:https://www.cnblogs.com/riskyer/p/3398015.html
Copyright © 2011-2022 走看看