zoukankan      html  css  js  c++  java
  • 洛谷1339 热浪

    题目描述

    The good folks in Texas are having a heatwave this summer. Their Texas Longhorn cows make for good eating but are not so adept at creating creamy delicious dairy products. Farmer John is leading the charge to deliver plenty of ice cold nutritious milk to Texas so the Texans will not suffer the heat too much.

    FJ has studied the routes that can be used to move milk from Wisconsin to Texas. These routes have a total of T (1 <= T <= 2,500) towns conveniently numbered 1..T along the way (including the starting and ending towns). Each town (except the source and destination towns) is connected to at least two other towns by bidirectional roads that have some cost of traversal (owing to gasoline consumption, tolls, etc.). Consider this map of seven towns; town 5 is the

    source of the milk and town 4 is its destination (bracketed integers represent costs to traverse the route):

                              [1]----1---[3]-
                             /               
                      [3]---6---[4]---3--[3]--4
                     /               /       /|
                    5         --[3]--  --[2]- |
                            /        /       |
                      [5]---7---[2]--2---[3]---
                            |       /
                           [1]------
    

    Traversing 5-6-3-4 requires spending 3 (5->6) + 4 (6->3) + 3 (3->4) = 10 total expenses.

    Given a map of all the C (1 <= C <= 6,200) connections (described as two endpoints R1i and R2i (1 <= R1i <= T; 1 <= R2i <= T) and costs (1 <= Ci <= 1,000), find the smallest total expense to traverse from the starting town Ts (1 <= Ts <= T) to the destination town Te (1 <= Te <= T).

    德克萨斯纯朴的民眾们这个夏天正在遭受巨大的热浪!!!他们的德克萨斯长角牛吃起来不错,可是他们并不是很擅长生產富含奶油的乳製品。Farmer John此时以先天下之忧而忧,后天下之乐而乐的精神,身先士卒地承担起向德克萨斯运送大量的营养冰凉的牛奶的重任,以减轻德克萨斯人忍受酷暑的痛苦。

    FJ已经研究过可以把牛奶从威斯康星运送到德克萨斯州的路线。这些路线包括起始点和终点先一共经过T (1 <= T <= 2,500)个城镇,方便地标号為1到T。除了起点和终点外地每个城镇由两条双向道路连向至少两个其它地城镇。每条道路有一个通过费用(包括油费,过路费等等)。

    给定一个地图,包含C (1 <= C <= 6,200)条直接连接2个城镇的道路。每条道路由道路的起点Rs,终点Re (1 <= Rs <= T; 1 <= Re <= T),和花费(1 <= Ci <= 1,000)组成。求从起始的城镇Ts (1 <= Ts <= T)到终点的城镇Te(1 <= Te <= T)最小的总费用。

    输入输出格式

    输入格式:
    第一行: 4个由空格隔开的整数: T, C, Ts, Te

    第2到第C+1行: 第i+1行描述第i条道路。有3个由空格隔开的整数: Rs, Re和Ci

    输出格式:
    一个单独的整数表示从Ts到Te的最小总费用。数据保证至少存在一条道路。

    输入输出样例

    输入样例#1: 复制
    7 11 5 4
    2 4 2
    1 4 3
    7 2 2
    3 4 3
    5 7 5
    7 3 3
    6 1 1
    6 3 4
    2 4 3
    5 6 3
    7 2 1
    输出样例#1: 复制
    7
    说明

    【样例说明】

    5->6->1->4 (3 + 1 + 3)

    spfa裸题,要用邻接表否则空间会炸。

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn=6300;
    int t,c,ts,te,cnt,head[maxn],q[maxn*2],dis[maxn];
    bool vis[maxn];
    struct Edge{
        int next,w,to;
    }edge[2*maxn];
    inline void add(int bg,int ed,int v){
        edge[++cnt].to=ed;
        edge[cnt].w=v;
        edge[cnt].next=head[bg];
        head[bg]=cnt;
    }
    inline void spfa(){
        int h=0,f=1;
        q[1]=ts;
        dis[ts]=0;
        vis[ts]=1;
        while(h<f){
            int u=q[++h];
            vis[u]=0;
            for(register int i=head[u];i;i=edge[i].next){
                if(dis[edge[i].to]>dis[u]+edge[i].w){
                    dis[edge[i].to]=dis[u]+edge[i].w;
                    if(!vis[edge[i].to]){
                        q[++f]=edge[i].to;
                        vis[edge[i].to]=1;
                    }
                }
            }
        }
    }
    int main(){
        memset(dis,0x3f,sizeof dis);
        scanf("%d%d%d%d",&t,&c,&ts,&te);
        for(register int i=1;i<=c;i++){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            add(x,y,z);
            add(y,x,z);
        }spfa();
        printf("%d",dis[te]);
    }
  • 相关阅读:
    Mac 安装FFMpeg 与 FFmpeg 格式转换
    django channels
    python3 coroutine
    python中关于sql 添加参数
    python导包的问题
    python中的列表
    django中用model生成数据库表结构
    docker
    博客大神地址
    Bean复制的几种框架性能比较(Apache BeanUtils、PropertyUtils,Spring BeanUtils,Cglib BeanCopier)
  • 原文地址:https://www.cnblogs.com/sdfzsyq/p/9677181.html
Copyright © 2011-2022 走看看