zoukankan      html  css  js  c++  java
  • POJ1505:Copying Books 解题心得

    原题:

    Description

    Download as PDF
     

    Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.


    Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered $1, 2, dots, m$) that may have different number of pages ( $p_1, p_2, dots, p_m$) and you want to make one copy of each of them. Your task is to divide these books among k scribes, $k le m$. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers $0 = b_0 <
b_1 < b_2, dots < b_{k-1} le b_k = m$ such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

    Input 

    The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k$1 le k le m le 500$. At the second line, there are integers $p_1, p_2, dots p_m$ separated by spaces. All these values are positive and less than 10000000.

    Output 

    For each case, print exactly one line. The line must contain the input succession $p_1, p_2, dots p_m$ divided into exactly kparts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.


    If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

    Sample Input 

    2
    9 3
    100 200 300 400 500 600 700 800 900
    5 4
    100 100 100 100 100
    

    Sample Output 

    100 200 300 400 500 / 600 700 / 800 900
    100 / 100 / 100 / 100 100
    

    题意:给一些书,这些书有不同的页数,让把这些书分成k份,必须是连续的,问这些份中页数和的最大值最小是多少。

    思路:首先可以用二分枚举出最大的最小值,然后输出的时候从后向前判断输出,这种最大值最小化的问题在书上这样

    介绍到:

    代码:

    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    int a[505];
    int main( )
    {
        int t;
        cin >> t;
        while (t--){
            int m, k; 
            long long mid;
            long long total=0;
            cin >> m >> k;
            for (int i = 0; i < m; i++){
                scanf("%d", &a[i]);
                total += a[i];
            }
            cout << total << endl;
            long long left = 0, right = total;
            while (left<right){
                mid = (left + right) / 2;
                if (k*mid >= total)
                    right = mid;
                else
                    left = mid+1;
            }
            cout << left<<' '<<right << endl;
        }
        return 0;
    }
  • 相关阅读:
    ios 适应屏幕
    用于重新编译的工具和命令
    SSRS 的简单使用(二)
    SSRS 的简单使用(一)
    优化SqlServer--数据压缩
    优化SQLServer——表和分区索引
    关于tempdb的一些注意事项
    关于事务的隔离级别和处理机制的理解
    SQL Server中的锁的简单学习
    sqlserver还原数据库失败,sql2008备份集中的数据库备份与现有的xxx数据库不同
  • 原文地址:https://www.cnblogs.com/shawn-ji/p/4711772.html
Copyright © 2011-2022 走看看