zoukankan      html  css  js  c++  java
  • poj2828

    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 17891   Accepted: 8863

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source

        题目意思:有n个数,进行n次操作,每次操作有两个数pos, ans。pos的意思是把ans放到第pos 位置的后面,pos后面的数就往后推一位。最后输出每个位置的ans。

        思路:根据题 目可知,最后插入的位置的数才是最终不变的数,所以可以从最后的输入作第1个放入,依此类推,倒插入。在插入时也有一定的技术,首先创建一棵空线段树时,每个节点记录当前范围内有多少个空位置。在插入时,要注意,一个数放入之后那么这个位置就不用管了,那么树中所有的空位置就是余下的数所对应的位置,也就是把余下的数又可以看作是一个新的集合。那么每次插入都是当前集合的第1次放。

    #include<iostream>
    #include<cstdio>
    using namespace std;
    const int N=200005;
    struct node{
        int l,r,w;
    }tree[3*N];
    int n,id,pos[N],val[N],ans[N];
    void build(int k,int left,int right){
        tree[k].l=left;
        tree[k].r=right;
        tree[k].w=right-left+1;//  w记录这个区间有多少的空位。
        int mid=(left+right>>1);
        if(left<right){
            build(k<<1,left,mid);
            build(k<<1|1,mid+1,right);
        }
    }
    void updata(int k,int pos){
        tree[k].w--;//  这个区间增加了一人,区间空位-1。
        if(tree[k].l==tree[k].r){
            id=tree[k].l;return;
        }
        if(tree[k<<1].w>=pos) updata(k<<1,pos);
        else{
            pos-=tree[k<<1].w;
            updata(k<<1|1,pos);
        }
    }
    int main(){
        while(scanf("%d",&n)==1){
            build(1,1,n);
            for(int i=1;i<=n;i++)
                scanf("%d%d",&pos[i],&val[i]);
            for(int i=n;i>=1;i--){
                updata(1,pos[i]+1);
                ans[id]=val[i];
            }
            for(int i=1;i<=n;i++)
                printf("%d ",ans[i]);
            putchar('
    ');
        }
        return 0;
    }
  • 相关阅读:
    sort函数详解
    C++重载运算符的规则详解
    poj3061-subsequence
    员工管理系统 :练习
    Jdbc 模拟登陆系统的练习
    有关String 的常用方法
    浅谈希尔排序-----摘录
    简单选择排序
    typedef 和define 的区别
    写博客的理由
  • 原文地址:https://www.cnblogs.com/shenben/p/5624886.html
Copyright © 2011-2022 走看看