zoukankan      html  css  js  c++  java
  • 3942: [Usaco2015 Feb]Censoring [KMP]

    3942: [Usaco2015 Feb]Censoring

    Time Limit: 10 Sec  Memory Limit: 128 MB
    Submit: 375  Solved: 206
    [Submit][Status][Discuss]

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

    FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

    Please help FJ determine the final contents of S after censoring is complete

    有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。

    
    
    

    Input

    The first line will contain S. The second line will contain T. The length of T will be at most that of S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).
     

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.

    
    
    

    Sample Input

    whatthemomooofun
    moo

    Sample Output

    whatthefun

    HINT

     

    Source

     

    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std;
    const int N=1e6+10;
    int n1,n2,top,fail[N],next[N];
    char s1[N],s2[N],s3[N];
    int main(){
        scanf("%s%s",s1+1,s2+1);
        n1=strlen(s1+1);n2=strlen(s2+1);
        fail[1]=0;
        for(int i=2;i<=n2;i++){
            int p=fail[i-1];
            while(p&&s2[i]!=s2[p+1]) p=fail[p];
            if(s2[i]==s2[p+1]) p++;
            fail[i]=p;
        }
        next[0]=0;
        for(int i=1;i<=n1;i++){
            s3[++top]=s1[i];
            int p=next[top-1];
            while(p&&s1[i]!=s2[p+1]) p=fail[p];
            if(s1[i]==s2[p+1]) p++;
            next[top]=p;//WA*1
            if(p==n2) top-=n2; 
        }
        s3[top+1]='';printf("%s",s3+1);//The output optimization
        return 0;
    }
  • 相关阅读:
    关于通过web页面删除数据记录的设计改进
    python 正则表达式用法
    每日日报
    每日日报
    每日日报
    每日日报
    每日日报
    每日日报
    每日日报
    每日日报
  • 原文地址:https://www.cnblogs.com/shenben/p/6251363.html
Copyright © 2011-2022 走看看