zoukankan      html  css  js  c++  java
  • USACO 1.1 Broken Necklace

      

    Broken Necklace

    You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

                    1 2                               1 2
                r b b r                           b r r b
              r         b                       b         b
             r           r                     b           r
            r             r                   w             r
           b               r                 w               w
          b                 b               r                 r
          b                 b               b                 b
          b                 b               r                 b
           r               r                 b               r
            b             r                   r             r
             b           r                     r           r
               r       r                         r       b
                 r b r                             r r w
                Figure A                         Figure B
                            r red bead
                            b blue bead
                            w white bead
    

    The beads considered first and second in the text that follows have been marked in the picture.

    The configuration in Figure A may be represented as a string of b's and r's, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

    Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

    Determine the point where the necklace should be broken so that the most number of beads can be collected.

    Example

    For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

    In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration will include the three symbols r, b and w.

    Write a program to determine the largest number of beads that can be collected from a supplied necklace.

    PROGRAM NAME: beads

    INPUT FORMAT

    Line 1: N, the number of beads
    Line 2: a string of N characters, each of which is r, b, or w

    SAMPLE INPUT (file beads.in)

    29
    wwwbbrwrbrbrrbrbrwrwwrbwrwrrb
    

    OUTPUT FORMAT

    A single line containing the maximum of number of beads that can be collected from the supplied necklace.

    SAMPLE OUTPUT (file beads.out)

    11
    

    OUTPUT EXPLANATION

    Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.

    wwwbbrwrbrbrrbrbrwrwwrbwrwrrb wwwbbrwrbrbrrbrbrwrwwrbwrwrrb
                           ****** *****
                           rrrrrb bbbbb  <-- assignments
                           5 x r  6 x b  <-- 11 total
    ===================================================================================================================================================================================================================


    思路: 模拟
    /*
    ID: shuyang1
    PROG: beads
    LANG: C++
    */
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    
    int main()
    {
        freopen("beads.in","r",stdin);
        freopen("beads.out","w",stdout);
        int num,n,i,j,p,q;
        char *s,flag1,flag2;
        int max=0;
        cin>>n;
        s=new char [n+1];
        cin>>s;
        for(i=n;i<2*n;i++)                   //把两个链子串在一起就可以成为链型了
        {
            if(s[i%n]!=s[(i+1)%n])
            {
                if(s[i%n]!='w') flag1=s[i%n];
                else if(s[(i+1)%n]=='r') flag1='b';
                else if(s[(i+1)%n]=='b') flag1='r';
                if(flag1=='r') flag2='b';
                if(flag1=='b') flag2='r';
                num=0;
    
                for(p=i;p>i-n;p--){
                    if(s[p%n]==flag1 || s[p%n]=='w') num++;
                    else break;
                }
                for(q=i+1;q<p+n+1;q++){
                    if(s[q%n]==flag2 || s[q%n]=='w') num++;
                    else break;
                }
            max=max>num?max:num;
            }
        }
        if(max==0) max=n;
        cout<<max<<endl;
    
        return 0;
    }
    

      








  • 相关阅读:
    linux进程管理类
    linux关机重启指令
    linux分区及磁盘挂载
    linux的运行级别
    property
    访问限制机制
    类的组合与封装
    继承与派生
    logging模块
    re模块
  • 原文地址:https://www.cnblogs.com/shenshuyang/p/2489610.html
Copyright © 2011-2022 走看看