zoukankan      html  css  js  c++  java
  • hdu 2795 线段数

    Billboard

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 3757    Accepted Submission(s): 1779


    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     
    Input
    There are multiple cases (no more than 40 cases).

    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     
    Output
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     
    Sample Input
    3 5 5 2 4 3 3 3
     
    Sample Output
    1 2 1 3 -1
     
    看完题目,我完全没有思路,因为这道题目是放在DIY里面的一个线段数和树状数组的栏目里面的,我尽量把它往线段数上靠拢,可是还是不知道怎么做,上网搜了一下,只要想通了就很简单了。
    代码:
    #include <iostream>
    #include <stdio.h>
    #include <stdlib.h>
    #include <string.h>
    using namespace std;
    
    const int M=200005;     //由于n 只有200000,所以不必担心数值太大。
    
    struct    Node{
        int left,right;
        int v;
    }tree[M*3];
    int ans;
    
    int max(int a, int b)
    {
        if(a>=b) return a;
        return b;
    }
    
    void build(int s, int t,int x, int r)
    {
        tree[r].left=s;
        tree[r].right=t;
        tree[r].v=x;
        int mid=(tree[r].left+tree[r].right)/2;
        if(tree[r].left==tree[r].right) return;
        build(s,mid,x,r*2);
        build(mid+1,t,x,r*2+1);
    }
    
    int    query(int s, int t, int x, int r)
    {
        if(tree[r].v<x)
            return 0;
        if(tree[r].left==tree[r].right && tree[r].v>=x)
        {
            tree[r].v-=x;
            ans=tree[r].left;
            return tree[r].v;
        }
        int mid=(tree[r].left+tree[r].right)/2;
        if(tree[r*2].v>=x)
        {
            return tree[r].v=max(query(s,mid,x,r*2),tree[r*2+1].v);   // 选左右两个子树中v较大的那个。
        }
        else
        {
            return tree[r].v=max(query(mid+1,t,x,r*2+1),tree[r*2].v);
        }
    }
    
    int main()
    {
        int h,w,n;
        while(scanf("%d%d%d",&h,&w,&n)!=EOF)
        {
            if(h>n) h=n;
            build(1,h,w,1);
            while(n--)
            {
                int v;
                ans=-1;
                scanf("%d",&v);
                query(1,h,v,1);
                printf("%d\n",ans);
    
            }
        }
        return 0;
    }
  • 相关阅读:
    vi 编辑内容中查找字符位置
    使用 Oracle GoldenGate 在 Microsoft SQL Server 和 Oracle Database 之间复制事务
    EBS R12 更改SYSADMIN密码
    两种步骤 更改 EBS R12界面LOGO以及内容
    Get Current LOV Query SQL
    Oracle Gateways透明网关访问SQL Server
    Oracle 数据集成的实际解决方案
    将SQLServer2005中的数据同步到Oracle中
    ogg实现oracle到sql server 2005的同步
    wince和window mobile winphone
  • 原文地址:https://www.cnblogs.com/shenshuyang/p/2602424.html
Copyright © 2011-2022 走看看