zoukankan      html  css  js  c++  java
  • A + B Problem II

    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2 1 2 112233445566778899 998877665544332211
     
    Sample Output
    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
    水题,但注意数组大小以及输入输出的方向。
    #include<iostream>
    #include<cstring>
    using namespace std;
    void add(char s1[],char s2[])
    {
        int i,j,k;
        int a[1010],b[1010],len1,len2;
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        len1=strlen(s1);
        len2=strlen(s2);
        j=0;
        for(i=len1-1;i>=0;i--)
            a[j++]=s1[i]-'0';
            k=0;
        for(i=len2-1;i>=0;i--)
            b[k++]=s2[i]-'0';
        for(i=0;i<1010;i++)
        {    a[i]+=b[i];
            if(a[i]>=10)
            {
                a[i]-=10;
                a[i+1]++;
            }
        }
        for(i=1005;i>=0;i--)
        {
            if(a[i]) break;
        }
        for( ;i>=0;i--)
        cout<<a[i];
    }
    int main()
    {
        int i;
        char c[1010];
        char d[1010];
        int n;
        cin>>n;
        for(i=1;i<=n;i++)
        {
             cin>>c>>d;
             cout<<"Case "<<i<<":"<<endl;
             cout<<c<<" +"<<' '<<d<<" ="<<' ';
             add(c,d);
             cout<<endl;
             if(i!=n)
             cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Elasticsearch 深入5
    Elasticsearch 深入4
    Elasticsearch 深入3
    Elasticsearch 深入2
    Elasticsearch1简单深入
    Kibana简单操作Elasticsearch
    什么是非阻塞同步?
    面向对象之思考
    使用spring代码中控制事务
    mybatis 中使用oracle merger into
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/6528204.html
Copyright © 2011-2022 走看看