zoukankan      html  css  js  c++  java
  • Atcoder Grand Contest 107 A Biscuits

    A - Biscuits


    Time limit : 2sec / Memory limit : 256MB

    Score : 200 points

    Problem Statement

    There are N bags of biscuits. The i-th bag contains Ai biscuits.

    Takaki will select some of these bags and eat all of the biscuits inside. Here, it is also possible to select all or none of the bags.

    He would like to select bags so that the total number of biscuits inside is congruent to P modulo 2. How many such ways to select bags there are?

    Constraints

    • 1N50
    • P=0 or 1
    • 1Ai100

    Input

    Input is given from Standard Input in the following format:

    N P
    A1 A2 ... AN
    

    Output

    Print the number of ways to select bags so that the total number of biscuits inside is congruent to P modulo 2.


    Sample Input 1

    2 0
    1 3
    

    Sample Output 1

    2
    

    There are two ways to select bags so that the total number of biscuits inside is congruent to 0 modulo 2:

    • Select neither bag. The total number of biscuits is 0.
    • Select both bags. The total number of biscuits is 4.

    Sample Input 2

    1 1
    50
    

    Sample Output 2

    0
    

    Sample Input 3

    3 0
    1 1 1
    

    Sample Output 3

    4
    

    Two bags are distinguished even if they contain the same number of biscuits.


    Sample Input 4

    45 1
    17 55 85 55 74 20 90 67 40 70 39 89 91 50 16 24 14 43 24 66 25 9 89 71 41 16 53 13 61 15 85 72 62 67 42 26 36 66 4 87 59 91 4 25 26
    

    Sample Output 4

    17592186044416
    排列组合
    #include <iostream>
    #include <cstdio>
    #include <algorithm>
    #include <cstring>
    #include <cmath>
    #include <queue>
    #include <stack>
    #include <map>
    #include <vector>
    using namespace std;
    typedef long long ll;
    ll C(ll k,ll n)
    {
        ll pos=1;
        for(ll i=0;i<k;i++)
        {
            pos*=(n-i);
            pos/=(i+1);
        }
        /*for(ll i=0;i<k;i++)
            pos/=(i+1);*/
        return pos;
    }
    int main()
    {
        ll n,m,ans=0,pos=0,x,cnt=0;
        cin>>n>>m;
        for(ll i=1;i<=n;i++)
        {
            cin>>x;
            if(x%2==0) ans++;
            else pos++;
        }
        if(m==0)
        {
            cnt=1;
            ll nn=0,mm=0;
            for(ll i=1;i<=ans;i++)
                nn+=C(i,ans);
            for(ll i=2;i<=pos;i+=2)
                mm+=C(i,pos);
            cnt+=nn+mm+(nn*mm);
        }
        else
        {
            ll nn=0,mm=0;
            for(ll i=1;i<=ans;i++)
                nn+=C(i,ans);
            for(ll i=1;i<=pos;i+=2)
                mm+=C(i,pos);
            cnt+=(mm+(mm*nn));
        }
        cout<<cnt<<endl;
        return 0;
    }

  • 相关阅读:
    118/119. Pascal's Triangle/II
    160. Intersection of Two Linked Lists
    168. Excel Sheet Column Title
    167. Two Sum II
    172. Factorial Trailing Zeroes
    169. Majority Element
    189. Rotate Array
    202. Happy Number
    204. Count Primes
    MVC之Model元数据
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7145024.html
Copyright © 2011-2022 走看看