zoukankan      html  css  js  c++  java
  • E.Mastering Mastermind

    题目描述

    Mastermind is a two-person code breaking game which works as follows. The first person (the code maker) creates a sequence of n colored pegs (with duplicate colors allowed) and hides it from view.
    This sequence of pegs is the code.
    The second person (the code breaker) has the job of trying to determine the code maker’s code and she does so by making a series of guesses. Each guess also consists of n colored pegs. After each guess, the code maker gives the code breaker feedback about how close she is. This feedback consists of two number r and s, where
    • r = the number of pegs that are identical in both color and position in the code and the guess,and
    • s = the number of remaining pegs that are identical in color but not in the same position.
    For example, if the code is BACC (where we use different letters to represent colors) and the guess is CABB, then r = 1 (the A in the second position of both the code and the guess) and s = 2 (a B and C in the remaining three characters). Note that only one of the B’s in the guess will “match” with the single B in the code: once pegs in the code and the guess have been “matched” with each other, they can’t be matched with any other pegs.
    Your job in this problem is to determine r and s given a code and a guess.

    输入

    The input is a single line containing a positive integer n ≤ 50 (the length of the code) followed by two strings of length n — the first of these is the code and the second is the guess. Both code and guess are made up of upper-case alphabetic characters.

    输出

    Output the values of r and s for the given input.

    样例输入

    4 BACC CABB
    

    样例输出

    1 2
    
    CODE:

    #include <stdio.h>

    #include <string.h>

    void dele(char *p)

    {

          char *i;

          for(i=p+1;*i!='';p++,i++)

               *p=*i;

          *p='';

    }

    int main()

    {

          int n,r=0,s=0,j,i;

          char *p1;

          char a[52],b[52];

          while(scanf("%d",&n)!=EOF)

          {

               getchar();

               for(i=0;i<n;i++)

                     scanf("%c",&a[i]);

               a[i]='';

              getchar();        

               for(i=0;i<n;i++)

                     scanf("%c",&b[i]);

               b[i]='';

               for(i=0;i<strlen(a);i++)

               {

                     if(a[i]==b[i])

                     {

                          r++;

                          p1=&a[i];

                          dele(p1);

                          p1=&b[i];

                          dele(p1);

                          i--;

                     }

               }

               for(i=0;i<strlen(a);i++)

               {

                     for(j=0;j<strlen(b);j++)

                     {

                          if(a[i]==b[j])

                          {

                                s++;

                                p1=&a[i];

                                dele(p1);

                                p1=&b[j];                   

                                dele(p1);

                                j--;

                                i--;

                          }

                     }

               }

               printf("%d %d",r,s);

          }

          return 0;

    }

  • 相关阅读:
    MATLAB中的SFunction的用法(C语言)
    OpenGL中的转换矩阵
    MATLAB读取和写入Excel文件
    一阶微分方程的求解
    三对角矩阵(Tridiagonal Matrices)的求法:Thomas Algorithm(TDMA)
    CarSim与Simulink联合仿真
    三次样条插值(Cubic Spline Interpolation)及代码实现(C语言)
    在Simulink中创建库
    轮胎的魔术公式(Magic Fomula)模型
    C#中的编译时的类型与运行时的类型
  • 原文地址:https://www.cnblogs.com/shu233/p/5575573.html
Copyright © 2011-2022 走看看