zoukankan      html  css  js  c++  java
  • Icesugar Gourd

    3083: Ice-sugar Gourd

    描述

    Ice-sugar gourd, “bing tang hu lu”, is a popular snack in Beijing of China. It is made of some fruits threaded by a stick. The complicated feeling will be like a both sour and sweet ice when you taste it. You are making your mouth water, aren’t you?

    I have made a huge ice-sugar gourd by two kinds of fruit, hawthorn and tangerine, in no particular order. Since I want to share it with two of my friends, Felicia and his girl friend, I need to get an equal cut of the hawthorns and tangerines. How many times will I have to cut the stick so that each of my friends gets half the hawthorns and half the tangerines? Please notice that you can only cut the stick between two adjacent fruits, that you cannot cut a fruit in half as this fruit would be no good to eat.

    输入

    The input consists of multiply test cases. The first line of each test case contains an integer, n(1 <= n <= 100000), indicating the number of the fruits on the stick. The next line consists of a string with length n, which contains only ‘H’ (means hawthorn) and ‘T’ (means tangerine).
    The last test case is followed by a single line containing one zero.

    输出

    Output the minimum number of times that you need to cut the stick or “-1” if you cannot get an equal cut. If there is a solution, please output that cuts on the next line, separated by one space. If you cut the stick after the i-th (indexed from 1) fruit, then you should output number i to indicate this cut. If there are more than one solution, please take the minimum number of the leftist cut. If there is still a tie, then take the second, and so on.

    样例输入

     

    4
    HHTT
    4
    HTHT
    4
    HHHT
    0

    样例输出

     

    2
    1 3
    1
    2
    -1

     

    最多切两刀可以分只要找到第一刀的位置,一段的位置一定是第一道开始的n/2个,找这个点的时候用一下替换的思想,如果直接查找会超时。

    #include<bits/stdc++.h>
    using namespace std;
    int main()
    {
      std::ios::sync_with_stdio(false);
      int n;
      while(cin>>n)
      {
          if(n==0) break;
          int cct=0,cch=0,ct=0,ch=0;
          char s[100010];
          for(int i=0;i<n/2;i++)
            {
                cin>>s[i];
                if(s[i]=='H')
                {
                    cch++;
                    ch++;
                }
                else
                {
                    cct++;
                    ct++;
                }
            }
         for(int i=n/2;i<n;i++)
         {
             cin>>s[i];
                if(s[i]=='H')
                    cch++;
                else
                    cct++;
         }
         if(cch%2!=0||cct%2!=0)
            cout<<"-1"<<endl;
         else
         {
             if(ch==cch/2&&ct==cct/2)
             {
                 cout<<"1"<<endl;
                 cout<<n/2<<endl;
             }
             else
             {
                 for(int i=0;i<n/2;i++)
                 {
                    if(s[i]=='H'&&s[i+n/2]!='H')
                    {
                        ch--;
                        ct++;
                    }
                    else if(s[i]=='T'&&s[i+n/2]!='T')
                    {
                        ct--;
                        ch++;
                    }
                 if(ch==cch/2&&ct==cct/2)
                 {
                     cout<<"2"<<endl;
                     cout<<i+1<<" "<<i+(n/2)+1<<endl;
                     break;
                 }
                 }
             }
         }
      }
    }
  • 相关阅读:
    Kafka 配置说明
    Ubuntu中网络配置问题
    vuecli全家桶搭建个人博客并迁移nuxtjs由后端服务渲染页面
    记录vim模式快捷键
    开发常用mac软件推荐(JetBrains IntelliJ IDEA 2019 for Mac, Parallels Desktop 15 for Mac,cleanmymac, MindNode 7 for mac 思维导图软件)
    gulp4 多页面项目管理打包(html, es6,less编译压缩版本控制)
    Adobe Photoshop 2021 for mac(PS 2020) v22.0.0中文激活破解版
    git 常用命令使用,git bash通用命令
    mac百度网盘破解版免费
    好久木来了,一直忙于项目太忙(tailan),今天讲讲vuecli3.0的使用
  • 原文地址:https://www.cnblogs.com/sjhhh/p/11575182.html
Copyright © 2011-2022 走看看