zoukankan      html  css  js  c++  java
  • [结题报告]10041 Vito's Family Time limit: 3.000 seconds


      Problem C: Vito's family 

    Background 

    The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.

    Problem 

    Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

    Input 

    The input consists of several test cases. The first line contains the number of test cases.

    For each test case you will be given the integer number of relatives r ( 0 < r < 500) and the street numbers (also integers) $s_1, s_2, \ldots, s_i, \ldots, s_r$ where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.

    Output 

    For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij= |si-sj|.

    Sample Input 

    2
    2 2 4 
    3 2 4 6
    

    Sample Output 

    2
    4

    参考代码:
    这道题求这个人家搬到何处使得他走邻居路程最短,其实就是求中位数.首先,我讲所输入的若干个数字进行排序(数字输入前,还有其他的输入,案例个数,要输入的数字个数),我采用的是冒泡,紧接着,就是找出中位数,(奇数的中位数就是中间的那个数,而偶数的中位数是中间的那2个数的平均数.),找到中位数后,将其与各个数的差相加即可.
    #include"stdio.h"
    int main(void)
    {
        int t,n,i,j,swap,temp,s,sum,b;
        int a[30000];
        scanf("%d",&t);
        while(t--)
        {   sum=0;
            scanf("%d",&n);
            for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            for(i=0;i<n-1;i++)           //冒泡排序      
            {
                swap=0;
                for(j=0;j<n-i-1;j++)         
                if(a[j]<a[j+1])
                {
                    swap=1;
                    temp=a[j+1];
                    a[j+1]=a[j];
                    a[j]=temp;
                }
                if(!swap)break;
               }
            if(n%2==0)                    //求出中位数 
            s=(a[n/2-1]+a[n/2])/2;         
            else
            s=a[n/2];
            for(i=0;i<n;i++)
            {
             b=s-a[i];
             if(b<0)
             b=b*-1;               
             sum=sum+b;
            }
            printf("%d\n",sum);
        }
        return 0;
    }
  • 相关阅读:
    11 Vue3 UI Framework Card 组件
    12 Vue3 UI Framework 打包发布
    15 Vue3 UI Framework 完工部署
    【译】使用 Visual Studio 调试外部源代码
    IntelliJ JSP 格式化问题
    JSP 学习笔记 | 五、MVC模式和三层架构 & JSP 案例实战
    JSP使用MySQL数据库报错java.lang.ClassNotFoundException: com.mysql.jdbc.Driver
    通过Navicate for MySQL导入SQL文件
    MAVEN 配置和基本使用
    JSP 学习笔记 | 二、JSP 脚本 & 案例实现 & 缺点分析
  • 原文地址:https://www.cnblogs.com/sjy123/p/2923620.html
Copyright © 2011-2022 走看看