zoukankan      html  css  js  c++  java
  • 天大复试机试练习_002

    acm.tju.edu.cn原题

    During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

    For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

    Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

    1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

    Years (both Haab and Tzolkin) were denoted by numbers 0, 1, ... , where the number 0 was the beginning of the world. Thus, the first day was:

    • Haab: 0. pop 0
    • Tzolkin: 1 imix 0

    Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

    Input

    The date in Haab is given in the following format:

    NumberOfTheDay. Month Year

    The first line of the input contains the number of the input dates in the input. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

    Output

    The date in Tzolkin should be in the following format:

    Number NameOfTheDay Year

    The first line of the output contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

    Sample Input

    3
    10. zac 0
    0. pop 0
    10. zac 1995
    

    Sample Output

    3
    3 chuen 0
    1 imix 0
    9 cimi 2801

    参考答案

    其实不难,理解题意即可。

    #include <iostream>
    #include <string>
    #include <vector>
    #include <sstream>
    using namespace std;
    
    vector<string> split(const string& s, const string& c) {
    	vector<string> result;
    	string::size_type pos1, pos2;
    	pos2 = s.find(c);
    	pos1 = 0;
    	while (string::npos != pos2) {
    		result.push_back(s.substr(pos1, pos2 - pos1));
    		pos1 = pos2 + c.size();
    		pos2 = s.find(c, pos1);
    	}
    	if (pos1 != s.length()) {
    		result.push_back(s.substr(pos1));
    	}
    	return result;
    
    }
    
    template<typename T>
    int find(T arr[], int n, T x) {
    	int i = 0;
    	int index = -1;
    	for (i = 0; i < n; i++) {
    		if (x == arr[i]) {
    			index = i;
    		}
    	}
    	return index;
    }
    
    int main()
    {
    	int n, day, month, year;
    	string line;
    	stringstream ss;
    	string Haab[19] = { "pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac", "ceh", "mac", "kankin", "muan", "pax", "koyab", "cumhu", "uayet" };
    	string Tzolkin[20] = { "imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau" };
    	cin >> n;
    	cin.ignore();
    	
    	while (n > 0) {
    		getline(cin, line);
    		vector<string> v = split(line," ");
    		ss << v[0].substr(0, v[0].length() - 1);
    		ss >> day;
    		ss.clear();
    		month = find<string>(Haab, 19, v[1]);
    		ss << v[2];
    		ss >> year;
    		ss.clear();
    		// cout << day << " " << month << " " << year << endl;
    
    		int totaldays = day + month * 20 + year * 365 + 1;
    		cout << totaldays % 13 << " " << Tzolkin[totaldays % 20 - 1]<< " " << totaldays/260 << endl;
    
    		n--;
    	}
        return 0;
    }
     
  • 相关阅读:
    python基础之列表解析
    初学者学习python2还是python3?
    给曾经是phper的程序员推荐个学习网站
    详解python2 和 python3的区别
    Python如何进行中文注释
    import方法引入模块详解
    详解python 局部变量与全局变量
    131-19. 删除链表的倒数第N个节点
    65.django中关于跨域访问设置
    130-283. 移动零
  • 原文地址:https://www.cnblogs.com/skyeisgood/p/12466399.html
Copyright © 2011-2022 走看看