zoukankan      html  css  js  c++  java
  • 2456 Aggressive cows

     Aggressive cows

    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 23866   Accepted: 11141

    Description

    Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

    His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

    Input

    * Line 1: Two space-separated integers: N and C 

    * Lines 2..N+1: Line i+1 contains an integer stall location, xi

    Output

    * Line 1: One integer: the largest minimum distance

    Sample Input

    5 3
    1
    2
    8
    4
    9

    Sample Output

    3

    Hint

    OUTPUT DETAILS: 

    FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

    Huge input data,scanf is recommended.
     

     尝试了剪枝 结果运行时间并没有什么区别(注释掉的地方是剪枝)

    #include <stdio.h>
    #include <iostream>
    #include <cstring>
    #include <vector>
    #include <algorithm>
    const int si = 100010, inf = 1000000000 + 10;
    using namespace std;
    int N, COW;
    int ar[si];
    
    bool c(int dis) {
        int pre = 0, finished = 1;
        for (int i = 1; i < N && finished < COW; i++) {
            //if (ar[N - 1] - ar[pre] < dis * (COW - finished)) return false;
    	//剪枝 剩下COW - finished头牛 每头牛需要dis的距离
            if (ar[i] - ar[pre] >= dis) {
                finished++;
                pre = i;
            }
        }
        return finished >= COW;
    }
    int main() {
        cin >> N >> COW;
        for (int i = 0; i < N; i++) scanf("%d", &ar[i]);;
        sort(ar, ar + N);
        int l = 1, m, r = inf;
        while (l < r - 1) {
            m = l + r >> 1;
            if (c(m)) l = m;
            else r = m;
        }
        cout << l << endl;
        return 0;
    }
    
  • 相关阅读:
    LeetCode 50: Pow(x, n)
    Codility 1: equilibrium
    LeetCode 49: Anagrams
    crackme160--(5)
    crackme160--(4)
    魔兽显血改键工具的脱壳和修改
    crackme160--(3)
    crackme160--(1)
    python-装饰器
    编程语言C++01-C++入门学习路线
  • 原文地址:https://www.cnblogs.com/smatrchen/p/10586013.html
Copyright © 2011-2022 走看看