zoukankan      html  css  js  c++  java
  • hdu 1969 Pie

    Pie

    Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 778 Accepted Submission(s): 299
     
    Problem Description
    My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

    My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

    What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
     
    Input
    One line with a positive integer: the number of test cases. Then for each test case:
    ---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
    ---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
     
    Output
    For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
     
    Sample Input
    3
    3 3
    4 3 3
    1 24
    5
    10 5
    1 4 2 3 4 5 6 5 4 2
     
    Sample Output
    25.1327
    3.1416
    50.2655
     
    比较坑的一道题,题意很关键,给定n个饼,饼的半径可以不一样,现在给m+1个人分饼,要求每个人分得的面积
    相同,但是每个人的饼只能是一块的,即不能由两块或多块拼接起来,求每个人能得到的最大面积
    思路:上面红色部分的字很关键,,否则就是一道简单的数学题了,,用二分查找做,假定饼总面积是是s,那么能得到的最大面积的理想值是   s/人数  ,但是加了限制条件后就不一定能够取到了,而最坏的情况是0,即没人得到饼,所以需要在0---s/人数中用二分法取值 即每个人能得到的最大面积,好好体会下代码红色部分
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<cmath>
    #include<algorithm>
    using namespace std;
    #define pi  acos(-1)  //新学的一个函数,包含在头文件cmath中
    double s[10001];
    int main()
    {
        int cas,p,n,r;
        cin>>cas;
        while(cas--)
        {
            scanf("%d %d",&n,&p);
            double  sum=0;
            int r1;
            for(int i=1;i<=n;i++)
            {
                scanf("%d",&r1);
                s[i]=r1*r1*pi;
                sum+=s[i];
            }
            p++;
            double l=0,r=sum/p,mid;
            int num=0;
            while(r-l>=1e-6)
            {
                num=0;
                mid=(r+l)/2.0;
               
    for(int i=1;i<=n;i++)
                      num+=(int)(s[i]/mid);  ///这段代码我简直是膜拜啊,,注意强制转换不要写成(int)s[i]/mid;

                if(num<p)     //对应的饼数<人数,说明一张饼分大了
                    r=mid;
                else
                    l=mid;
            }
            printf("%.4lf ",mid);
        }
        return 0;
    }
  • 相关阅读:
    C程序设计语言学习笔记(二)
    字符串处理代码(国际化转换C++版) 荣
    取得MySQL数据库表,列信息的SQL语句 荣
    C++中,以类成员函数指针作为参数对std::map中的元素进行迭代处理 荣
    我的我的C#数据库操作类(与大家交流) 荣
    以较少代码实现DataGrid的排序,翻页,删除等功能 荣
    批处理文件的学习 荣
    DLL内存管理模板类 荣
    我的C++数据库访问库 荣
    我的C++数据库访问库临界区处理类 荣
  • 原文地址:https://www.cnblogs.com/smilesundream/p/6642563.html
Copyright © 2011-2022 走看看