zoukankan      html  css  js  c++  java
  • 南阳483--Nightmare(Bfs)

    Nightmare

    时间限制:1000 ms  |  内存限制:65535 KB
    难度:4
    描述
    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

    Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

    Here are some rules:
    1. We can assume the labyrinth is a 2 array.
    2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
    3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
    4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
    5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
    6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
    输入
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
    There are five integers which indicate the different type of area in the labyrinth:
    0: The area is a wall, Ignatius should not walk on it.
    1: The area contains nothing, Ignatius can walk on it.
    2: Ignatius' start position, Ignatius starts his escape from this position.
    3: The exit of the labyrinth, Ignatius' target position.
    4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.

    输出
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.

    样例输入
    3 3 
    2 1 1 
    1 1 0 
    1 1 3 
    4 8 
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1 
    1 0 0 0 0 0 0 1 
    1 1 1 4 1 1 1 3 
    样例输出
    -1
    上传者

    ACM_林志强

    这个题题目要求不能标记,但是要注意是4的情况要标记为1;

    #include <queue>
    #include <cstdio> 
    #include <cstring>
    #include <iostream>
    using namespace std;
    int map[10][10], ac[4][2] = {010, -1, -1010};
    struct Maze
    {
        int x, y, step, eng;
    } r, s, t;
    int n, m; 
    int Bfs(int a, int b)
    {
        r.x = a; r.y = b; r.step = 0; r.eng = 6;
        queue<Maze> Q;
        Q.push(r);
        while(!Q.empty())
        {
            s = Q.front(); Q.pop();
            for(int i = 0; i < 4; i++)
            {
                t.x = s.x + ac[i][0]; 
                t.y = s.y + ac[i][1];
                t.step = s.step + 1;
                t.eng = s.eng - 1;
                if(t.x >= 0 && t.x < n && t.y >= 0 && t.y < m && map[t.x][t.y] != 0 && t.eng > 0)    
                {
                    if(map[t.x][t.y] == 3)
                        return t.step;
                    if(map[t.x][t.y] == 4)
                    {
                        map[t.x][t.y] = 1;    /***********************/
                        t.eng = 6;
                    }
                    Q.push(t);
                }
            } 
        }
        return -1;
    }
    int main()
    {
        int T;
        scanf("%d", &T);
        while(T--)
        {
            int x, y, i, j;
            scanf("%d %d", &n, &m);
            for(i = 0; i < n; i++)    
                for(j = 0; j < m; j++)
                {
                    scanf("%d", &map[i][j]);
                    if(map[i][j] == 2)
                    {
                        x = i; 
                        y = j;
                    }
                }
            printf("%d ", Bfs(x, y));
        }
        return 0;
    }        
  • 相关阅读:
    web之用FileUpload上传文件
    利用LinQ技术和lambd表达式进行增删改查
    weibform中Application、ViewState对象和分页
    webform中Session和Cookies对象的用法、登录保持
    点击input框弹出输入法 ,底部footer内容就会被顶上去的问题
    实现input密码框显示/隐藏的功能
    Elasticsearch 入门
    svn 提示错误 :Failed to run the WC DB work queue associated with 解决办法
    provider:命名管道提供程序,error:40
    ECMAScript (Javascript)位运算符
  • 原文地址:https://www.cnblogs.com/soTired/p/4778905.html
Copyright © 2011-2022 走看看