zoukankan      html  css  js  c++  java
  • hdoj 4006 The kth great number(优先队列)

    The kth great number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
    Total Submission(s): 9415    Accepted Submission(s): 3756


    Problem Description
    Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
     
    Input
    There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.
     
    Output
    The output consists of one integer representing the largest number of islands that all lie on one line.
     
    Sample Input
    8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
     
    Sample Output
    1 2 3
    Hint
    Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
     
    Source
     
    #include <queue>
    #include <vector>
    #include <iostream>
    using namespace std;
    
    int main()
    {
        char op[10];
        int n, k, num;
        while(cin>>n >> k)    
        {
            //priority_queue<int, vector<int>, cmp>q;
            priority_queue<int, vector<int>, greater<int> >q;  //小元素在队首, 队内元素有序;
            for(int i=0; i<n; i++)
            {
                cin>> op;
                if(op[0]=='I')
                {
                    cin>>num;
                    if(q.size() < k)
                    {
                        q.push(num); 
                        continue;
                    }
                    if(q.size() == k)
                    {
                        if(num> q.top())
                        {
                            q.pop(); q.push(num);
                        }    
                    }
                }    
                else
                {
                    cout<<q.top()<<'
    ';
                }
            }
        }
        return 0;
    }
    #include <vector> 
    #include <queue>
    #include <iostream>
    using namespace std;
    int main()
    {
        priority_queue<int, vector<int> > q;//默认大元素在队首 ; 
        q.push(10);
        q.push(8);
        q.push(20);
        cout<<q.top()<<'
    ';
        return 0;
    }
  • 相关阅读:
    webyestem(伊莱博)票据管理(ver1.0)数据库设计
    MicrosoftNorthwind(电子商务)数据库设计
    WebForm三层架构
    WebForm带接口工厂模式的三层架构
    VS 2008 C#代码调试进C++代码设置/远程调试
    C# 中使用指针
    互操作性——使用C/C++类型的非托管函数基础
    Perforce使用指南_forP4V
    [转]DotNet程序之找BUG心得
    C# 对XML基本操作总结
  • 原文地址:https://www.cnblogs.com/soTired/p/5524718.html
Copyright © 2011-2022 走看看