zoukankan      html  css  js  c++  java
  • [ACM

    Eddy's digital Roots

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 11   Accepted Submission(s) : 7

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

    The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

    Input

    The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

    Output

    Output n^n's digital root on a separate line of the output.

    Sample Input

    2
    4
    0
    

    Sample Output

    4
    4
    

    Author

    eddy


    解题思路:

    九余数的定理:一个数对9取余等于这个数各位数相加的和对9取余,例如  123 %9 = (1+2+3)%9,所以题目中要求把一个数的各个位加起来直到是个不大于9的数,就等于直接对这个数对9取余。比如 789  7+8+9=24   2+4=6     789%9=6 ,  另外公式 比如4的4次方最后对9取余 等于 {  [(4*4)%9]*4%9}*4%9  。

    代码:

    #include <iostream>
    using namespace std;
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            int i;
            int temp=n;
            for(i=2;i<=n;i++)
                temp=temp*n%9;
            if(temp==0)
                cout<<9<<endl;
            else
                cout<<temp<<endl;
        }
    }
    

    运行截图:



  • 相关阅读:
    python 格式化 json输出
    python
    回顾2013
    C扩展Python
    C扩展Python
    Python
    Python interview preparing
    Python用smtplib发送邮件
    Python 安装路径, dist-packages 和 site-packages 区别
    nginx worker_cpu_affinity使用方法
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697822.html
Copyright © 2011-2022 走看看