zoukankan      html  css  js  c++  java
  • [ACM]Elevator

    Problem Description

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input

    There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

    Output

    Sample Input

    1 2
    3 2 3 1
    0
    

    Sample Output

    17
    41
    

    Author

    ZHENG, Jianqiang

    Source

    ZJCPC2004

    解题思路:

    开一个数组用来保存输入的楼层数,变量time为总共的时间,初始化为0,从数组的第个数开始,依次比较当前数与前一个数的大小,分情况time+=(6或4)*(大数-小数),最后time再加上数组中的一个数(楼层数)所用的时间,再加上所有楼层停留的时间。


    代码:

    #include <iostream>
    using namespace std;
    int fl[102];
    int main()
    {
        int n;
        while(cin>>n&&n)
        {
            int i;
            for(i=0;i<n;i++)
                cin>>fl[i];
            int time=0;
            for(i=1;i<n;i++)
            {
                if(fl[i]>fl[i-1])//比较
                    time=time+6*(fl[i]-fl[i-1]);
                if(fl[i]<fl[i-1])
                    time=time+4*(fl[i-1]-fl[i]);
            }
            cout<<time+6*fl[0]+5*n<<endl;
        }
        return 0;
    }
    

    运行截图:



  • 相关阅读:
    Mysql日志管理
    Mysql 安全和DCL语句
    Mysql DDL语句之视图
    Mysql增删改查(DML、DQL)
    Mysql操作之部分DDL语句
    如何做事情
    temp
    asp.net入门
    希望尽快回忆起来
    需求?
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697838.html
Copyright © 2011-2022 走看看