zoukankan      html  css  js  c++  java
  • [ACM]Max Sum

    Problem Description
    Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
     

    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
     

    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
     

    Sample Input
    2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
     

    Sample Output
    Case 1: 14 1 4 Case 2: 7 1 6


    代码:

    #include <iostream>
    using namespace std;
    int a[100002];//用来存放数字
    int main()
    {
        int T,N,i,j;
        cin>>T;
        for(i=1;i<=T;i++)
        {
            cin>>N;
            for(j=0;j<N;j++)
                cin>>a[j];
            int start=0,end=0,sum=0,s=0,e,max;//start起始位置,end结尾位置,sum为连续数字的和,s为起始位置变量,和start有关,e为结尾位置变量,max为所求的最大值
            max=a[0];
            for(j=0;j<N;j++)
            {
                e=j;//记录运算到得位置,也是末位置
                sum=sum+a[j];
                if(sum>max)
                {
                    max=sum;
                    start=s;
                    end=e;
                }
                if(sum<0)//这里写成sum+a[j]<a[j]比较好理解,sum为负数,舍去前边的,从下一位开始从头运算
                {
                    s=j+1;//记录新运算的起始位置
                    sum=0;
                }
            }
            cout<<"Case "<<i<<":"<<endl;
            cout<<max<<" "<<start+1<<" "<<end+1<<endl;
            if(i<=T-1)
                cout<<endl;//注意格式
    
        }
        return 0;
    }


    运行截图:


  • 相关阅读:
    pt-tcp-model
    (转)从史上八大MySQL宕机事故中学到的经验
    pt-query-digest
    DNS生效时间
    Python之uuid模块
    一个IO的传奇一生
    Python之Queue模块
    利用freemarker 静态化网页
    FreeMarker教程
    模板引擎freemarker的简单使用教程
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697855.html
Copyright © 2011-2022 走看看