zoukankan      html  css  js  c++  java
  • [ACM] hdu 1241 Oil Deposits(DFS)

    Oil Deposits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 10647    Accepted Submission(s): 6179


    Problem Description
    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
     

    Input
    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
     

    Output
    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
     

    Sample Input
    1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
     

    Sample Output
    0 1 2 2
     

    Source



    解题思路:

    做一个DFS简单题,找回对搜索的感觉。还好这次一次AC。

    代码:

    #include <iostream>
    #include <string.h>
    using namespace std;
    char maze[102][102];
    int n,m;
    
    void dfs(int x,int y)
    {
        if(x<1||y<1||x>n||y>m)
            return;
        if(maze[x][y]=='*')
            return ;
        maze[x][y]='*';
        for(int i=-1;i<=1;i++)
            for(int j=-1;j<=1;j++)
        {
            int a=x+i;
            int b=y+j;
            dfs(a,b);
        }
    }
    
    int main()
    {
        while(cin>>n>>m&&n)
        {
            for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
            cin>>maze[i][j];
            int count=0;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=m;j++)
            {
                if(maze[i][j]=='@')
                {
                    dfs(i,j);
                    count++;
                }
            }
            cout<<count<<endl;
        }
    return 0;
    }
    


  • 相关阅读:
    C#操作SQLite 报错 (Attempt to write a readonly database)
    JS判断字符输入个数(数字英文长度记为1,中文记为2,超过长度自动截取)
    JueryUI插件的简单应用(一):介绍及第一个示例
    在VS2008(Winform)中使用WebService
    Oracle触发器使用
    C# 创建Windows服务。服务功能:定时操作数据库
    aspnet前后台条件下根目录的读取
    xshell实现端口转发
    (转)使用FreeType实现矢量字体的粗体、斜体、描边、阴影效果
    D3D坐标系统和几何DirectX Griaphic学习
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697908.html
Copyright © 2011-2022 走看看