zoukankan      html  css  js  c++  java
  • HDU

    Description

    The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

    The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Dicontiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

    Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi+Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

    Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and D(b) Three space-separated integers representing a check-out: 2, Xi, and Di

    Output

    * Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

    Sample Input

    10 6
    1 3
    1 3
    1 3
    1 3
    2 5 5
    1 6
    

    Sample Output

    1
    4
    7
    0
    5

    看了好久的题目,结果还是去搜了一下题解,哎,实力不够,

    去掉题目背景,就是给你一个[1,n]的区间,初始时,整个区间为空,在区间进行俩个操作:

    1) 输入 1 D :在区间上从左到右找出第一个连续的长度为D 的空间,并将该区间填满,输出区间的端点,若不存在,输出0

    2) 输入 2 a b: 将区间[a,a+b-1] 填满

    这是线段树比较难的一种了吧,区间合并,其中我参照ACM大牛的做法,用msum表示当前节点的最长连续区间长度,lsum表示当前节点以左端点位起点的最长连续长度,同理,rsum

    表示当前节点以右端点为结尾的最长区间长度,代码中我会加入具体注释,以便以后自己理解:

    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<cmath>
    #include<algorithm>
    using namespace std;

    #define INF 0x3f3f3f3f
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1

    const int MX = 55555;
    int msum[MX<<2], lsum[MX<<2], rsum[MX<<2], cover[MX<<2];//cover表示要执行的操作,要初始化为负一

    void PushUp(int rt, int len) {
      lsum[rt] = lsum[rt<<1];
      rsum[rt] = rsum[rt<<1|1];
      if (lsum[rt] == len - (len>>1)) lsum[rt] += lsum[rt<<1|1];//如果左边的最大区间长度最大了,那就合并右儿子的左区间
      if (rsum[rt] == len>>1) rsum[rt] += rsum[rt<<1];//如果右边区间最大了,那就合并左儿子的右区间
      msum[rt] = max(lsum[rt<<1|1] + rsum[rt<<1], max(msum[rt<<1], msum[rt<<1|1]));//取最长的连续区间长度记录
    }

    void Build(int l, int r, int rt) {
      msum[rt] = lsum[rt] = rsum[rt] = r - l + 1;//初始化时每个区间都是最大值
      cover[rt] = -1;/*之所以要初始化为-1,是因为有延迟标记的存在,遇到-1则不用继续向下更新了,如果要清除或者填满更深的节点,把延迟标记往下传递填满是1,清除是0*/
      if (l == r) {
      return ;
      }
      int m = (l + r)>>1;
      Build(lson);
      Build(rson);
    }
    void PushDown(int rt, int len) {
      if (cover[rt] != -1) {
        cover[rt<<1] = cover[rt<<1|1] = cover[rt];
        msum[rt<<1] = lsum[rt<<1] = rsum[rt<<1] = cover[rt] ? 0 : len - (len>>1);/*下面还会遇到相似的代码,大致的意思是如果操作是0(清空)就把连续区间变到最大,

    因为清空了嘛*/
        msum[rt<<1|1] = lsum[rt<<1|1] = rsum[rt<<1|1] = cover[rt] ? 0 : (len>>1);
        cover[rt] = -1;
      }
    }

    void UpDate(int L, int R, int add, int l, int r, int rt) {
      if (L <= l && r <= R) {
      cover[rt] = add;//记录操作
      msum[rt] = lsum[rt] = rsum[rt] = add ? 0 : r - l + 1;
      return ;
    }
    PushDown(rt, r - l + 1);
      int m = (l + r)>>1;
      if (L <= m) UpDate(L, R, add, lson);
      if (R > m) UpDate(L, R, add, rson);
      PushUp(rt, r - l + 1);
    }

    int Query(int q, int l, int r, int rt) {
      if (l == r) {
      return l;
      }
      PushDown(rt, r - l + 1);
      int m = (l + r)>>1;
      if (msum[rt<<1] >= q) return Query(q, lson);
      else if (lsum[rt<<1|1] + rsum[rt<<1] >= q) return m - rsum[rt<<1] + 1;
      else return Query(q, rson);

    }
    int main() {
      //freopen("input.txt", "r", stdin);
      int n, m;
      while (scanf("%d %d", &n, &m) != EOF) {
        Build(1, n, 1);
        while (m--) {
          int Q;
          scanf("%d", &Q);
          if (Q == 1) {
            int a;
            scanf("%d", &a);
            if (msum[1] < a) {//如果最大的连续区间都先于a,就没有答案了
            puts("0");
            continue;
           }
            int ans = Query(a, 1, n, 1);
            printf("%d ", ans);
            UpDate(ans, ans + a - 1, 1, 1, n, 1);
           } else {
            int a, b;
            scanf("%d %d", &a, &b);
            UpDate(a, a + b - 1, 0, 1, n, 1);
           }
         }
       }
       return 0;
    }

  • 相关阅读:
    用gdb调试python多线程代码-记一次死锁的发现
    使用docker部署standalone cinder
    Linux上open-iscsi 的安装,配置和使用
    Windows上Ruby开发环境的配置
    在Pypi上发布自己的Python包
    docker X509 证书错误的终极解决办法
    oslo_config中的DuplicateOptError坑
    删除emacs临时文件
    xfce4快捷键设置
    设置emacs启动窗口的两种方法
  • 原文地址:https://www.cnblogs.com/steamedbun/p/5699890.html
Copyright © 2011-2022 走看看