zoukankan      html  css  js  c++  java
  • hdu1045 Fire Net

    Fire Net

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 65   Accepted Submission(s) : 39

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

    A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

    Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

    The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

    The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



    Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

    Input

    The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

    Output

    For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

    Sample Input

    4
    .X..
    ....
    XX..
    ....
    2
    XX
    .X
    3
    .X.
    X.X
    .X.
    3
    ...
    .XX
    .XX
    4
    ....
    ....
    ....
    ....
    0
    

    Sample Output

    5
    1
    5
    2
    4
    

    Source

    Zhejiang University Local Contest 2001
    #include <iostream>
    #include<algorithm>
    #include<cstdio>
    using namespace std;
    
    char mp[5][5];
    int i,n,ans;
    
    int check(int x,int y)
    {
        for(int i=x-1;i>=0;i--)
          {
              if (mp[i][y]=='p') return 0;
              if (mp[i][y]=='X') break;
          }
        for(int j=y-1;j>=0;j--)
        {
            if (mp[x][j]=='p') return 0;
            if (mp[x][j]=='X') break;
        }
        return 1;
    }
    void dfs(int k,int num)
    {
        int x=k/n,y=k%n;
        if (k==n*n)
              {
                  ans=max(num,ans);
                   return;
              }
        if (mp[x][y]=='.')
            if (check(x,y))
            {
                mp[x][y]='p';
                dfs(k+1,num+1);
                mp[x][y]='.';
            }
        dfs(k+1,num);
        return;
    }
    int main()
    {
        while(scanf("%d",&n),n)
        {
            for(i=0;i<n;i++)
                scanf("%s",&mp[i]);
            ans=0;
            dfs(0,0);
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    ajax
    文件下载--getOutputStream输出二进制字符
    文件上传功能实现代码
    java动态生成验证码
    项目中用到的jar包简介(2)
    python字符串的常见操作
    python切片使用方法(超详细)
    for循环结合range使用方法
    python使用while循环实现九九乘法表
    石家庄云修科技有限公司
  • 原文地址:https://www.cnblogs.com/stepping/p/5648408.html
Copyright © 2011-2022 走看看