zoukankan      html  css  js  c++  java
  • HDU1548:A strange lift

    A strange lift

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 64   Accepted Submission(s) : 29

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
    Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

    Input

    The input consists of several test cases.,Each test case contains two lines.
    The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
    A single 0 indicate the end of the input.

    Output

    For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

    Sample Input

    5 1 5
    3 3 1 2 5
    0

    Sample Output

    3

    #include <iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<climits>
    using namespace std;
    int a,b,ans,i,n;
    int f[205];
    int step[205];
    void dfs(int floor,int k)
    {
        if (floor==b)
        {
            if (ans==-1) ans=k;
               else ans=min(ans,k);
            return;
        }
        if (floor>n || floor<1) return;
        if (k>=step[floor]) return;
        step[floor]=k;
        dfs(floor+f[floor],k+1);
        dfs(floor-f[floor],k+1);
        return;
    }
    int main()
    {
        while(scanf("%d",&n),n)
        {
            scanf("%d%d",&a,&b);
            for(i=1;i<=n;i++)
                {
                    scanf("%d",&f[i]);
                    step[i]=INT_MAX;
                }
            ans=-1;
            dfs(a,0);
            printf("%d\n",ans);
        }
        return 0;
    }
    
    
    /*bfs: 第二种方法
    #include <iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<queue>
    using namespace std;
    
    int a,b,ans,i,n;
    int f[205];
    int vis[205];
    struct node
    {
        int floor,step;
    };
    int check(int a)
    {
        if(a<1 || a>n || vis[a]) return 0;
         return 1;
    }
    int main()
    {
        while(scanf("%d",&n),n)
        {
            scanf("%d%d",&a,&b);
            for(i=1;i<=n;i++)
                scanf("%d",&f[i]);
          if (a==b) {printf("0\n"); continue;}
          memset(vis,0,sizeof(vis));
          queue<node>s;
          node p;
          p.floor=a;
          p.step=0;
          s.push(p);
          vis[a]=1;
          ans=-1;
          while(!s.empty())
          {
              p=s.front();
              s.pop();
              int x=p.floor+f[p.floor];
              if (check(x))
              {
                  vis[x]=1;
                  node q;
                  q.floor=x;
                  q.step=p.step+1;
                  s.push(q);
                  if(x==b) {ans=q.step;break; }
              }
              x=p.floor-f[p.floor];
              if (check(x))
              {
                  vis[x]=1;
                  node q;
                  q.floor=x;
                  q.step=p.step+1;
                  s.push(q);
                  if(x==b) {ans=q.step;break; }
              }
          }
          printf("%d\n",ans);
        }
        return 0;
    }*/
    /*
    之前用递归和bfs做的,这次用的是dijkstra
    */
    #include <iostream>
    #include<cstdio>
    #include<cstring>
    #include<queue>
    #include<algorithm>
    using namespace std;
    const int inf=0x7fffffff;
    int n,m,st,ed;
    int vis[205],dis[205],mp[205][205];
    int  dijkstra()
    {
       memset(vis,0,sizeof(vis));
       for(int i=1;i<=n;i++) dis[i]=mp[st][i]==0?inf:1;
       vis[st]=1;
       for(int i=1;i<n;i++)
       {
           int mindis=inf,k;
           for(int j=1;j<=n;j++)
            if (!vis[j] && mindis>dis[j]) mindis=dis[j],k=j;
           vis[k]=1;
           if (k==ed) return dis[k];
           for(int j=1;j<=n;j++)
            if (!vis[j] && mp[k][j])
              dis[j]=min(dis[j],dis[k]+1);
       }
       return -1;
    }
    int main()
    {
        while(scanf("%d",&n) && n!=0)
        {
            scanf("%d%d",&st,&ed);
            memset(mp,0,sizeof(mp));
            for(int i=1;i<=n;i++)
            {
                int x;
                scanf("%d",&x);
                if(i+x<=n) mp[i][i+x]=1;
                if(i-x>0) mp[i][i-x]=1;
            }
            if (st==ed) {printf("0\n");continue;}
            printf("%d\n",dijkstra());
        }
        return 0;
    }
  • 相关阅读:
    SpringMVC 集成 Swagger【问题】 No qualifying bean of type RequestMappingHandlerMapping found for dependency
    【leetcode】medianofTwoSortedArrays
    记一次apache+php调优
    java 文件定位
    Java知识探究一:关于IO类库
    180app待选内容
    SQlserver 2000 根据spid 查询执行的SQL
    (转)Flashbuilder4.5中文版破解方法
    代码整洁之道
    手机分辨率基础知识(DPI,DIP计算)
  • 原文地址:https://www.cnblogs.com/stepping/p/5667552.html
Copyright © 2011-2022 走看看